Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Standalone repo project from 3.0.0 archetype will not run out-of-the-box

See original GitHub issue

I’m submitting a … (check one with “x”)

[X ] bug report => search github for a similar issue or PR before submitting
[ ] feature request

Expected Behavior

  1. Create a new project with mvn archetype:generate -Dfilter=org.alfresco:
  2. Select option 4 (org.alfresco.maven.archetype:alfresco-platform-jar-archetype)
  3. The project creates successfully.
  4. Switch to root of the project.
  5. Run chmod u+x
  6. Run ./

Expect the server to start up successfully.

Current Behavior

Currently, at step 6 from above, the following error will occur:

[ERROR] Failed to execute goal org.alfresco.maven.plugin:alfresco-maven-plugin:3.0.0:run (default-cli) on project actions-tutorial-repo: Unable to execute mojo: Unable to find artifact. Failure to find org.alfresco:alfresco:war:5.2.e in was cached in the local repository, resolution will not be reattempted until the update interval of alfresco-public has elapsed or updates are forced

Possible Solution

A workaround is to edit pom.xml and change the SDK version to 3.0.0-SNAPSHOT.

Your Environment

  • Alfresco SDK version used: 3.0.0
  • Alfresco version used: Default for SDK
  • Output of command ‘mvn -version’:

Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T10:41:47-06:00) Maven home: /opt/local/share/java/maven3 Java version: 1.8.0_77, vendor: Oracle Corporation Java home: /Library/Java/JavaVirtualMachines/jdk1.8.0_77.jdk/Contents/Home/jre Default locale: en_US, platform encoding: UTF-8 OS name: “mac os x”, version: “10.11.6”, arch: “x86_64”, family: “mac”

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:10 (9 by maintainers)

github_iconTop GitHub Comments

wkamdemcommented, Aug 7, 2017

following this tutorial of jpotts. i have the following problem runing the run.bat file.

[ERROR] Failed to execute goal org.alfresco.maven.plugin:alfresco-maven-plugin:3 .0.0:run (default-cli) on project someco-mvn-tutorial-repo: Unable to execute mo jo: java.lang.reflect.InvocationTargetException: Invalid plugin descriptor for o rg.apache.tomcat.maven:tomcat7-maven-plugin:2.2 (C:\Users\wt.m2\repository\org
apache\tomcat\maven\tomcat7-maven-plugin\2.2\tomcat7-maven-plugin-2.2.jar), Plug in’s descriptor contains the wrong group ID: org.apache.axis2, Plugin’s descript or contains the wrong artifact ID: axis2-ant-plugin, Plugin’s descriptor contain s the wrong version: 1.4 -> [Help 1] [ERROR] [ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit ch. [ERROR] Re-run Maven using the -X switch to enable full debug logging. [ERROR] [ERROR] For more information about the errors and possible solutions, please rea d the following articles: [ERROR] [Help 1] xception java.lang.NoClassDefFoundError: de/schlichtherle/truezip/fs/FsLockController$1Sy nc at de.schlichtherle.truezip.fs.FsLockController.sync(FsLockController.ja va:240) at at de.schlichtherle.truezip.fs.FsDecoratingController.sync(FsDecoratingC at de.schlichtherle.truezip.fs.FsFalsePositiveArchiveController.sync(FsF at de.schlichtherle.truezip.fs.FsManager.sync( at de.schlichtherle.truezip.fs.FsDefaultManager.sync(FsDefaultManager.ja va:190) at de.schlichtherle.truezip.fs.FsSyncShutdownHook$ Caused by: java.lang.ClassNotFoundException: de.schlichtherle.truezip.fs.FsLockC ontroller$1Sync at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass( at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadCl ass( at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm .java:247) at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm .java:239) … 7 more

  • Maven 3.5
  • alfresco-platform-jar-archetype version 3.0.0-beta-5. Also not working on 3.0.0


jpottscommented, Jun 13, 2017

I noticed that some of my standalone repo projects using SDK 3.0.0 no longer have this problem, so I tested with an out-of-the-box project this morning and this behavior is no longer exhibited. Unfortunately, I’ve made multiple upgrades since the original problem (to Maven 3.5 and to Mac OS 10.12.5) so I am not sure what fixed it.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Alfresco Content Services SDK 3
If an Alfresco Platform is not currently running, one will be started to execute the ... project from Archetype: alfresco-al linone-archetype:3.0.0-SNAPSHOT ...
Read more >
Maven Configuration Issue error | Selenium Forum
Hi Ashish,. I tried in Eclipse Luna for the Live Project. Attached word for your reference also the command prompt details below.
Read more >
Maven Getting Started Guide
To create our first Maven project we are going to use Maven's archetype mechanism. An archetype is defined as an original pattern or...
Read more >
Maven archetype:generate plugin 3.0 how to specify remote ...
How can I do the same command using maven-archetype-plugin:3.0? I tried to use archetypeCatalog=repo.url , but it doesn't work this way, I can...
Read more >
Maven Setup For Testing Java Applications - rieckpil
As part of my Custom Maven Archetype open-source project on GitHub, I've published ... Creating our own Maven Archetype is almost no effort....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found