Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Plex login doesn't work on mobile

See original GitHub issue

Describe the bug

When I try logging in with plex on mobile, the plex login screen never shows up. I am able to log into authentik with plex auth using my computer.

Here is the documentation that I followed to setup plex login with authentik.

To Reproduce

Steps to reproduce the behavior:

  1. Go on iPhone 12 Pro iOS 15.6.1 (I used safari and brave in private mode)
  2. Go to my traefik reverse proxy url that points to authentik
  3. Click on the plex icon
  4. This is where the issue happens, the plex login page doesn’t load

Expected behavior I expected for the plex login screen to show up and be able to login with it.

Screenshots Sorry I don’t have a screenshot, but it is stuck on the screen “Authenticating with Plex…” with a spinning circle forever.


This was the only log that printed when I clicked on the Plex icon.

{"event":"/static/dist/flow/PlexLoginInit-4a6a3433.js","host":"","level":"info","logger":"authentik.router","method":"GET","remote":"","runtime":"0.967","scheme":"https","size":12783,"status":200,"timestamp":"2022-10-19T20:54:02-07:00","upstream":"","user_agent":"Mozilla/5.0 (iPhone; CPU iPhone OS 15_5 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.5 Mobile/15E148 Safari/604.1"}

Version and Deployment (please complete the following information):

  • authentik version: 2022.9.0
  • Deployment: docker in unRaid

Additional context I have the google auth working on both mobile and a computer.

Overseerr uses plex auth to log into the application. I noticed that when I click “sign in” it’ll open a new tab for the plex login.

Issue Analytics

  • State:closed
  • Created a year ago
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

jonathann92commented, Dec 1, 2022

@babariviere thanks for making the changes!

babarivierecommented, Dec 1, 2022

No problem!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Why can't the Plex app find or connect to my Plex Media Server?
General Troubleshooting · Sign out of your Plex account in both the app and Plex Media Server · Sign in to your Plex...
Read more >
Error logging in on mobile devices (iOS) : r/PleX - Reddit
Hey everyone! I've just started having a super strange problem. Every time I try to log in to plex on my ipad or...
Read more >
Unable to sign in with plex - Solved - Yatse community
Issue description: Logs: (Join files do not paste the content of the files here !) Screenshots: Additional information: i cant connect to plex....
Read more >
Can't Sign In to Plex (Solved) - Brave Community
I found the problem. It's Poper Blocker extension blocking the sign in page from loading. Disabling Poper Blocker on Plex solves the issue....
Read more >
Plex: Troubleshooting - Login - TiVo
Ensure that Plex Media Server is actually actively running · Disable any VPN on your computer or router · Disable any proxies being...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found