Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error: write EPIPE

See original GitHub issue

I was using gulp-imagemin before, which worked perfectly, but wanted to give gulp-image a try. But it’s failing with a strange error.

$ gulp image
[07:07:05] Using gulpfile /Volumes/Dev/Web/Node.js/NoobGuy/gulpfile.js
[07:07:05] Starting 'image'...
[07:07:05] Finished 'image' after 14 ms
Error: write EPIPE
    at exports._errnoException (util.js:907:11)
    at WriteWrap.afterWrite (net.js:785:14)

Here’s what I have in my gulpfile.js

var image = require('gulp-image');
gulp.task('image', function(){

I was using the same code with gulp-imagemin which worked properly. Am I doing something wrong?

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Reactions:7
  • Comments:15 (2 by maintainers)

github_iconTop GitHub Comments

bertalanimrecommented, Mar 14, 2017

Also waiting for an aswer. This is frustrating.

tomhoadcommented, Mar 5, 2018

For the record, on MacOS:

brew install libjpeg npm install --global jpegoptim-bin

Read more comments on GitHub >

github_iconTop Results From Across the Web

Error: write EPIPE when piping node output to "| head"
its work for me, I was trying to upload my code to aws ec2 but I face this error (Error: write EPIPE) (npm...
Read more >
what is a "write EPIPE" error? - Google Groups
I've done it a million times in the past but now I'm stuck on an error event. ... EPIPE means that writing of...
Read more >
EPIPE Error when uploading large file using nodejs #4399
EPIPE (Broken pipe): A write on a pipe, socket, or FIFO for which there is no process to read the data. Commonly encountered...
Read more >
Uncaught Execption, Error: write EPIPE - Node-RED Forum
2 May 16:53:42 - [info] Stopping flows 2 May 16:53:42 - [red] Uncaught Exception: 2 May 16:53:42 - [error] Error: write EPIPE at ......
Read more >
write EPIPE error on generating html to pdf
It could be that you are missing a package on your Dockerfile, can you kindly check the following post which had a similar...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found