Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

10updocker postinstall --silent fails

See original GitHub issue

Describe the bug When installing v2.8 on arch linux with nvm and node v12.20.1 the 10updocker postinstall --silent fails with Error : Command failed: /home/gbr/.nvm/versions/node/v12.20.1/lib/node_modules/wp-local-docker/node_modules/mkcert-prebuilt/1.2.0.bin -install

Some pointers:

Using the local CA at "/home/gbr/.local/share/mkcert" ✨
ERROR: failed to execute "certutil -A": exit status 255

certutil: function failed: SEC_ERROR_LEGACY_DATABASE: The certificate/key database is in an old, unsupported format.

An older version (2.7.0) of 10updocker was installing and running fine on node v10.0.0. Today I decided to update and got this error. Same happens on node stable v14.15.3.

Steps to Reproduce

  1. switch node version to 12.20.1 with nvm install 12.20.1
  2. run npm install -g wp-local-docker
  3. Error appears

Expected behavior installation finishes without errors

  • Device: Acer Aspire 7
  • OS: Arch Linux

Additional context I tried to find solutions for certutil: function failed: SEC_ERROR_LEGACY_DATABASE: The certificate/key database is in an old, unsupported format. to no avail.

EDIT: Until this is resoved, I downgraded to v2.7.0 on node 10.0.0 to be able to use this great tool

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:14 (4 by maintainers)

github_iconTop GitHub Comments

JanKruftcommented, Jun 8, 2021

@eugene-manuilov . Really great tool. ❤️ . One question What was the fix @issue176. The 2.8.1 is working well on my ubuntu (expept of the certs). on windows 10 it fails with the “.” issue. while installation

tomaleccommented, Feb 28, 2021

I managed to solve my problem with

# /etc/systemd/system/docker.service.d
ExecStart=/usr/bin/dockerd -H fd:// -H tcp://
Read more comments on GitHub >

github_iconTop Results From Across the Web

npm : Postinstall not running in docker - Stack Overflow
Try running install with --unsafe-perm option. When running as root, npm won't run any scripts. Alternatively, create a user in the ...
Read more >
wp-local-docker - npm
10updocker wpsnapshots pull <snapshot-id> This command pulls an existing snapshot from the repository into your current environment, replacing ...
Read more >
Receiving errors when trying to install wp-local-docker
When I run "npm install -g wp-local-docker" I get the following error. ... /d /s /c npm run 10updocker postinstall --silent npm ERR!...
Read more >
wp-local-docker-v2 - githubmemory
Update stuck while updating to 2.8.0 · 10updocker postinstall --silent fails · The use of ip gateway causing conflicts with provider gateways....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found