Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Loading cvimrc doesn't work

See original GitHub issue

Issue Description

I tried:

let configpath = '/path/to/your/.cvimrc'
set localconfig 

using both my home dir as ~ and my fully expanded home dir in two separate tries.

Both times, I restarted Chrome and opened the cvim options. I got a modal that said there was an error loading the configuration file.

Issue Analytics

  • State:open
  • Created 8 years ago
  • Comments:12

github_iconTop GitHub Comments

dabbegcommented, May 12, 2016

Checking “Allow access to file URLS” for cvim in the extension view of my browser and following the steps @mrap mentioned worked for me.

mrapcommented, Nov 12, 2015

The documentation for using set localconfig is a bit hidden in :help. But here’s how to do it.

  1. Add let configpath = '/path/to/your/.cvimrc' and set localconfig to your local cvimrc file.
  2. In browser, :source /path/to/your/.cvimrc
  3. Go to :settings and put only set localconfig in the cvimrc textarea.
  4. Click Save!
Read more comments on GitHub >

github_iconTop Results From Across the Web

vim - Not reading ~/.vimrc - Stack Overflow
Once you've loaded vim, :scriptnames will tell you exactly what Vim read. ... Open the vim_strace file and search for "vimrc" in the...
Read more >
GVIM on Windows not loading vimrc sometimes
I'm using GVIM 7.2 on Windows 7 and am having a problem with the vimrc file. When I open GVIM and then open...
Read more >
[SOLVED]vim not applying settings from my .vimrc
Meanwhile I found a proper workaround as vim -V shows off where it's trying to load files and when: $HOME/.vim/after/plugin/ directory is loaded...
Read more >
plugin system - how to load vim8 optional packages in vimrc?
The way to load vim8 optional packages in your vimrc is to use the :packadd! command, which will add them to your 'runtimepath'...
Read more >
Can I load .vimrc from a WSL path? · Issue #4740 - GitHub
I figured why it wasn't working: ~/.vimrc is a symbolic link and Windows doesn't seem to be able to resolve them; I can't...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found