Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error: undefined Unable to resolve module react-spring/native

See original GitHub issue
  • As soon as I installed the package on my react-native application, I started getting this issue, which is in the screenshot.
  • Tried doing these to remove the error:
rm -rf node_modules && rm -rf package-lock.json
cd ios && rm -rf Pods && rm -rf Podfile.lock && cd ..
npm install
cd ios && pod install
react-native start --reset-cache [in one terminal]
npm run ios [in another terminal]

I also, visited to see if I can install the missing package from this link @react-spring/native, but the docs says:

Note: This package is not compiled before being published, because Metro handles that for us, which means we get proper sourcemap support!

Did not work out for me. Still the same issue. My app is breaking. Any help would be highly appreciated.

Simulator Screen Shot - iPhone 12 - 2021-06-15 at 17 18 30

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:5 (1 by maintainers)

github_iconTop GitHub Comments

Danilqacommented, Jul 24, 2021

@Luca8991 the reasons is that you use the 9-th version of the react-spring. It doesn’t contain native part. Please, just downgrade it to “8.0.27” as in the sample project:

It helped me.

3DJakobcommented, Jul 2, 2021

Hey sorry for the late reply! The native version depends on react-spring however not the react version. Because of this, it would be a bad idea to include it in our module taking up unnecessary space for React users. Try running npm install react-spring and it should hopefully work.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Unable to Resolve Module in React Native App - Stack Overflow
I'm getting an error in React Native saying it can't resolve a module. It's saying a certain folder doesn't exist but the path...
Read more >
react-spring react native problem - Expo Snack
Error : Unable to resolve module 'react-spring/native.js' at Object.eval ... at eval (<anonymous>) at [snack internals] at Module.o ([snack internals] at ...
Read more >
Error: Unable to resolve module `util` – Split Help Center
Running bundle using React Native and Javascript SDK causes an error. Bundling failed: Error: Unable to resolve module `util`.
Read more >
undefined Unable to resolve module react-native-google-signin
ERROR [ Error : undefined Unable to resolve module react-native-google-signinPlease do like share and comment if you like the video please do ...
Read more >
Troubleshooting | React Navigation
You can install the latest versions by installing the packages again (e.g. npm install package-name ). I'm getting an error "Unable to resolve...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found