Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error running demo environment

See original GitHub issue

Hi 👋 Thanks @6eer for your work. Your code looks really promising.

I followed your instructions to deploy the demo environment. I ran ganache successfully (by forking mainnet), created the .env file and also ran demo_environment.js without issues, but when I either run bot_normalswap.js or bot_flashswap.js I’m getting the following error:

UnhandledPromiseRejectionWarning: Error: Returned values aren’t valid, did it run Out of Gas? You might also see this error if you are not using the correct ABI for the contract you are retrieving data from, requesting data from a block number that does not exist, or querying a node which is not fully synced.

Can you point me in the right direction or help me find out what is failling?

Issue Analytics

  • State:open
  • Created 2 years ago
  • Comments:7 (1 by maintainers)

github_iconTop GitHub Comments

interzone2commented, Aug 12, 2021

I discovered that the gasNeeded issue has been solved and no need to comment out the lines. Line 143 fixes the issue.

The problem with my running the bot related to not replacing the below fields in the .env file with the results from running :

node ./src/demo_environment.js -a
node ./src/demo_environment.js -b


**ADDR_ARBITRAGE_CONTRACT** = '0xD3167f135a9e003B1bF2CB81c0738Fdbc0C9124F'

**ADDR_TOKEN0** = '0x20526CEd6B8e4601B45Ec931b6B68b72c0DB249C'
**ADDR_TOKEN1** = '0x3806F6B92F899ACD32C8285Df70cB0f379A38713'

**ADDR_UTILS** = '0x79F86fDb626533F6ed19722D7CC3784ED24876dd'

kiidfreakcommented, Feb 28, 2022

@interzone2 how does line 143 fix the issue…mine still has the same issue running

Read more comments on GitHub >

github_iconTop Results From Across the Web

[SUPPORT] Environment issues when running Demo for v0.11
Running the demo setup as described here for v0.11 results in jar files missing error when running spark-submit and hive-sync commands.
Read more >
"Error running 'Test', Failed to prepare environment" happens ...
I have created a project in PyCharm and wanted to run Python scripts on a remote Linux server (RHEL 8.6). Setting up a...
Read more >
No valid Maven installation found. Either set the home ...
No valid Maven installation found. Either set the home directory in the configuration dialog or set the M2_HOME environment variable on your system...
Read more >
Configure Application resource step is giving error while ... - IBM
Now I am trying to run the operations of Development and Test environment and getting error in the step "Configure Application Resources".
Read more >
Troubleshooting AWS Cloud9
Error when running AWS Toolkit: "Your environment is running out of inodes, please increase 'fs.inotify.max_user_watches' limit." Notice: Failed to install ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found