Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

New version of checkbox has issues with multiselect = true + RowSelectionModel.selectActiveRow = true

See original GitHub issue

On examples like

If you turn on Checkbox multiselect and RowSelecitonModel.selectActiveRow

The new version will not allow multiselect to work.

Old version would allow you to select each row by the check box and have multiple selected. New version does not

     if (lookup[row] !== _selectedRowsLookup[row]) 
          delete _selectedRowsLookup[row];

The above is deleting the row even tho it is the same row.

The issue seems to be one of the commented out rows below.

     function toggleRowSelection(row) {
            if (_selectedRowsLookup[row]) {
                _grid.setSelectedRows($.grep(_grid.getSelectedRows(), function (n) {
                    return n != row
            } else {
+            //_grid.setActiveCell(row, getCheckboxColumnCellIndex());
+            //_grid.focus();

The set and then focus seems to be acting like a double click on the checkbox/row

Issue Analytics

  • State:open
  • Created 5 years ago
  • Comments:31 (20 by maintainers)

github_iconTop GitHub Comments

SatanEnglishcommented, Apr 10, 2019

@6pac @ghiscoding Sorry still haven’t found time to play with this again yet will try look within next couple of weeks

SatanEnglishcommented, Jun 18, 2019

@swatiwak I cannot replicate it sorry. Try getting the newer version and if it’s still an issue post a separate issue for it.

Read more comments on GitHub >

github_iconTop Results From Across the Web

jqGrid MultiSelect Problem - Stack Overflow
So I have a check all column. However when I click check all checkbox( the checkbox at header) it selects all checkboxes but...
Read more >
Solved: Multi Select Checkbox not getting unchecked
Solved: Hi, I'm new to power apps and I saw this video on how to do a multi select checkbox, (3) Multi Select...
Read more >
Checkbox Column not allowing multi select - Telerik
I am running into an issue where the multi select on checkboxes no longer works. Locally it works fine, but when I publish...
Read more >
javascript - Get checkbox value in multi select picklist
I have a few checkboxes displayed on a page ...
Read more >
Row Selection - JavaScript Data Grid
Set to true (or return true from function) to render a selection checkbox in ... All remaining rows have disabled checkboxes and cannot...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found