Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

ERROR: Cannot install -r python_requirements.txt

See original GitHub issue

While installing when using pip3 install -r python_requirements.txt I get:

ERROR: Cannot install -r python_requirements.txt (line 12), -r python_requirements.txt (line 20), -r python_requirements.txt (line 25), -r python_requirements.txt (line 26), -r python_requirements.txt (line 31), -r python_requirements.txt (line 34), -r python_requirements.txt (line 4), -r python_requirements.txt (line 45), -r python_requirements.txt (line 47), -r python_requirements.txt (line 48), -r python_requirements.txt (line 54), -r python_requirements.txt (line 56) and numpy==1.18.1 because these package versions have conflicting dependencies.

The conflict is caused by:
    The user requested numpy==1.18.1
    audiomate 6.0.0 depends on numpy==1.18.1
    ds-ctcdecoder 0.9.3 depends on numpy>=1.14.5
    h5py 2.10.0 depends on numpy>=1.7
    keras-preprocessing 1.1.2 depends on numpy>=1.9.1
    librosa 0.7.2 depends on numpy>=1.15.0
    numba 0.49.1 depends on numpy>=1.15
    opt-einsum 3.3.0 depends on numpy>=1.7
    resampy 0.2.2 depends on numpy>=1.10
    scikit-learn 0.24.0 depends on numpy>=1.13.3
    scipy 1.4.1 depends on numpy>=1.13.3
    tensorboard 2.4.0 depends on numpy>=1.12.0
    tensorflow 2.4.0 depends on numpy~=1.19.2

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

moejoe95commented, Jun 15, 2021

a solution could be to pass the --no-dependency flag:

pip3 install -r python_requirements.txt --no-dependencies

michelleespranitacommented, Jun 4, 2021

You could try to downgrade your pip version to 20.2.3, which allows you to install packages despite dependency conflicts.

Read more comments on GitHub >

github_iconTop Results From Across the Web

pip fails to install packages from requirements.txt
Sometimes the dependency is listed above the package it depend upon. The solution is simple: 1.pip install package_name 2.simply put the error ...
Read more >
Errors while running pip install -r requirements.txt - MongoDB
Hi,. I have same problem when I run the command in virtualenv in Window Command Prompt. (mflix_venv) C:\Program Files\MongoDB\M220P\mflix-python ...
Read more >
pip install -r requirements.txt fails · Issue #3 · deepmind/dqn_zoo
I created a new virtual environment and immediately tried to install the requirements, but ran into a version error: pip install -r ......
Read more >
pip freeze - pip documentation v22.3.1
This error occurs, for instance, when the command is installed only for another user, and the current user doesn't have the permission to...
Read more >
Installing private Python packages · Gemfury Dev Center
Once you have signed up for a Gemfury account and uploaded a few packages, you can install them via command-line, or with requirements.txt....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found