Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

2.168.0 does not work, permission issue, 2.165.2 worked fine

See original GitHub issue

Describe the bug Our CI testing started failing today without any change to our .yml or other setup; the only difference is that the GitHub runner was apparently updated from 2.165.2 (which worked fine) to 2.168.0 (which does not work).

We use the “checkout” v2 action, and this seems to fail. Inspecting the raw logs, we see:

2020-04-07T17:35:08.9585074Z [command]/usr/bin/git log -1
2020-04-07T17:35:08.9627094Z commit df7ef1ee005fead76cadffd594e05915452b3583
2020-04-07T17:35:08.9627421Z Author: XXXXXX YYYYYY <>
2020-04-07T17:35:08.9628050Z Date:   Tue Apr 7 10:11:38 2020 -0700
2020-04-07T17:35:08.9628245Z     Commit message
2020-04-07T17:35:08.9935859Z ##[error]Access to the path '/home/runner/runners/2.168.0/_diag/pages/2a8aec61-a697-428a-8919-a42ea1742359_02880bdf-4d66-515a-adeb-1569bc940d0f_1.log' is denied.

To Reproduce Steps to reproduce the behavior:

  1. In our case, just creating a pull request that causes the action to run is enough.

Our .yml file looks like this:

    runs-on: ubuntu-latest
        image: yandex/clickhouse-server
          - 9000:9000
          - /:/var/lib/clickhouse
      image: [some-repository]/[some-image-name]:latest
      - name: Checkout code
        uses: actions/checkout@v2

Expected behavior Existing .yml files that worked with version 2.165.2 should not break due to Github updating to 2.168.0.

Runner Version and Platform

2.165.2 (working) vs. 2.168.0 (non-working)

The OS is whatever Github actions uses.

What’s not working?

The checkout action fails due to a permissions error.

Job Log Output

See above.


I am not sure this is the right place to report the issue - if there is a more appropriate venue, please point me to it.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:16 (7 by maintainers)

github_iconTop GitHub Comments

vikmikcommented, Apr 7, 2020

Sent it just now 😃

TingluoHuangcommented, Apr 8, 2020

Glad you are unblocked and we understand the root cause, I am going to merge the PR and close this issue. Thanks for reporting this. 👍

Read more comments on GitHub >

github_iconTop Results From Across the Web

No results found

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found