question-mark

Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

gradlew not found after updating to 1.5.1

See original GitHub issue

Issue Description

After updating from mirakle:1.5.0 (works OK) to mirakle:1.5.1, I see this error when I try a build:

> Task :executeOnRemote
bash: ~/mirakle/my_project/gradlew: No existe el archivo o el directorio

Issue Analytics

  • State:closed
  • Created 7 months ago
  • Reactions:5
  • Comments:8 (3 by maintainers)

github_iconTop GitHub Comments

2reactions
JSpinercommented, Jun 8, 2022

I also worked fine in 1.5.0, but it doesn’t work in 1.5.1.

rsync is successfully worked. and I can see the synced folder. but executeOnRemote fail like below.

Task :executeOnRemote bash: ~/mirakle/KakaoT/gradlew: No such file or directory

I think, gradle’s project.task<Exec> wraps args once more with quotes("). for example,

$ ssh mainframer "~/mirakle/my_project/gradlew"
// works fine

$ ssh mainframer "\"~/mirakle/my_project/gradlew\""
bash: ~/mirakle/my_project/gradlew: No such file or directory
// an error like 1.5.1

@Adambl4 This code seems to have an effect, I think you can remove the quotes. https://github.com/Adambl4/mirakle/commit/c28383144c01148333b4731dcf4240758cfd892e#diff-5c5f3cc932f8a1ca09848c5c2466a8ce3872748600b75821773c3cedfb0e78b8R146

0reactions
Adambl4commented, Jun 20, 2022

Thank you guys for the report. It’s weird bug since it worked well in my macos to remote linux environment. I’ve removed the quotes. The only downside is without quotes it doesn’t work on Windows remote machine.

Read more comments on GitHub >

github_iconTop Results From Across the Web

gradlew command not found? - Stack Overflow
Run ./gradlew . It isn't on your path but is an executable that is present in the root directory of the project you...
Read more >
Upgrading your build from Gradle 7.x to the latest
Run gradle wrapper --gradle-version 7.6 to update the project to 7.6. ... or Test tasks, Gradle will now emit an error if this...
Read more >
Android Gradle plugin release notes - Android Developers
When you update Android Studio, you may receive a prompt to also update Gradle to the latest available version. You can choose to...
Read more >
gradlew: 'sh' is not recognized as an internal or external ...
Found this issue thread while investigating the same " 'sh' is not recognized" occurring on Windows 10 after upgrading to cordova-android.
Read more >
Changelog and Migration Guide - Detekt
Documentation for the upcoming version (next) can be found here. ... false negative SafeCast with no braces - #5479; Update gradle/wrapper-validation-action ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Dev.to Post

No results found

github_iconTop Related Hashnode Post

No results found