Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error - Failed to verify signature. Signature might have been tampered with.

See original GitHub issue

ZXPSignCmd certificate varification failed

Certificate is created successfully and zxp package as well. but while i try to verify it shows this error. Error - Failed to verify signature. Signature might have been tampered with.

Can anyone help me out from where this error coming?


Issue Analytics

  • State:open
  • Created 2 years ago
  • Comments:7 (4 by maintainers)

github_iconTop GitHub Comments

EarlyVisioncommented, Jun 13, 2022

Possible solution… had this issue and the problem was a little hidden file in the node-modules. I was doing that on Windows, so an easy way to identify the hidden file is to rung the dir command as follows: dir /A:H /B /s this will point you to the problematic file, once I got rid of it (was not a critical one, otherwise make unhidden), issue solved.

ErinFinnegancommented, Apr 8, 2022

OK, so, this has come up a couple of times, here’s an update:

The issue

  • A developer has reported an issue in Photoshop & AI (Illustrator) when they tried to download an asset from their server with Https.get using self-signed certificate authorization. However the same plugin has found to be working fine with ID (InDesign).
  • We found below errors when pswidget is using self-signed certificate authorization in Https.get to download an asset. Node doesn’t allow the self-signed certificate authorized connections. It is recommended to use a proper SSL Cert from a trusted source. Although for development we could use a few flags for node to bypass these checks(Try: rejectUnauthorize = false; Check… )
            In apiManager.js
            Error: self signed certificate
            at TLSSocket.onConnectSecure (node:_tls_wrap:1531)
            at TLSSocket.emit (node:events:378)
            at TLSSocket._finishInit (node:_tls_wrap:945)
            at TLSWrap.ssl.onhandshakedone (node:_tls_wrap:719)
  • ID on the other hand is pointing to web version of this plugin embedded inside an iframe, which is a totally different flow.


  • Please use a trusted certificate in production & try rejectUnauthorize = false for development purposes to bypass this problem.
Read more comments on GitHub >

github_iconTop Results From Across the Web

'Verify Signature Failed' error message appears - ATTK
This means that ATTK failed to verify the digital signature of binaries. This results from changing the root certificate from VeriSign to ...
Read more >
Error: "Authenticode signature verification failed" when ... - IBM
This issue can occur if the digital signature of the ISS installer ( ISS_Installer.exe ) is invalid.
Read more >
Able to sign successfully using ZXPSignCmdMac, but...
"Error - Failed to verify signature. Signature might have been tampered with." I'm confused as to why signing could appear successful, when ...
Read more >
ProxySG failed to upload image, with error message
Security signature verification failed, The requested system software image may have been tampered with. The event log shows:.
Read more >
Apple Mail warning: Unable to Verify Message Signature
The digital signature is incorrect. The message may have been tampered with or corrupted since signed by (sender's name). the reason is due...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found