question-mark

Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unable connect when are used an Android Device Emulator

See original GitHub issue

Issue Description

Describe the bug

When I tried to connect an Android Device Emulator created at the Android Studio (AVD), Airtest’s log show me this message: Failed to execute ADB commands, please read Docs But don’t have any topics about AVD in the doc. Sometimes the Ide crashed when tried to connect, but this is not usual.

To Reproduce Steps to reproduce the behavior:

  1. Go to ‘Devices’
  2. Click on ‘refresh ADB’
  3. Click on ‘connect’
  4. See the error on log

Expected behavior Connect on Device (Emulator or not) normally

Screenshots If applicable, add screenshots to help explain your problem. adb_airtestide avd_capture

python version: python3.5

airtest version: V1.0.0(PREVIEW)

Smartphone (please complete the following information):

  • Device: [Emulator Nexus 5]
  • OS: [e.g. Android 8.1]
  • more information if have

Additional context Add any other context about the problem here.

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:8 (5 by maintainers)

github_iconTop GitHub Comments

1reaction
rockywhispercommented, Oct 17, 2018

@vitorc Hi, buddy. I’ve tried the Nuexus5 with Android8.1, seems fine.

Here’s my operation: test-issues

If you still can’t connect it, try the latest version of AirtestIDE 😃

0reactions
vitorccommented, Nov 9, 2018

@rockywhisper Thanks. It’s Worked with the new version. Thanks a lot.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Troubleshoot known issues with Android Emulator
This page lists known issues, workarounds, and troubleshooting tips for the Android Emulator. If you encounter an issue not listed here or ...
Read more >
Android emulator not able to access the internet - Stack Overflow
Open Android emulator and go to the Extended Controls. Then go to the setting => proxy(Tab), ...
Read more >
Android Emulator is Not Able to Access the Internet
Android Emulator is Not Able to Access the Internet ... An Android Emulator is used to simulate Android devices on any computer. It...
Read more >
Android Emulator Troubleshooting - Xamarin - Microsoft Learn
Launch the emulator from the Android Device Manager (select your virtual device and click Start). · Open a command prompt and go to...
Read more >
Unable to Connect to Android Emulator
I create an android emulator (default settings for Pixel device) device in the ... option to try to use that Visual Studio connecting...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Dev.to Post

No results found

github_iconTop Related Hashnode Post

No results found