Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Hotswap share not working

See original GitHub issue

I’m submitting a … (check one with “x”)

[ x] bug report => search github for a similar issue or PR before submitting
[ ] feature request

Refresh webscripts on the path src/main/resources/META-INF/resources/components/upload/dnd-upload-custom.js with goal mvn compile alfresco:refresh-share does refresh but the changes aren’t visible.

Your Environment

<alfresco.sdk.version>3.0.1</alfresco.sdk.version> <alfresco.platform.version>5.2.f</alfresco.platform.version> <alfresco.share.version>5.2.e</alfresco.share.version>

Issue Analytics

  • State:closed
  • Created 6 years ago
  • Comments:5

github_iconTop GitHub Comments

gehrigacommented, Feb 2, 2018

Hi @binduwavell , I’ve encountered the same problem. The mentioned file or path ain’t a Webscript JS, but a client-side file. src/main/resources/META-INF/resources is the correct path for placing such a file, especially when you’re producing a JAR module and not an AMP.

I’ve tried several hours to make Share reload changes there, but without success. Neither through “refresh webscripts”, setting “disable-resource-caching” in share-config-custom.xml to true, nor through HotSwapAgent’s capabilities.

I think this has to be addressed by the SDK. Especially because it has been possible with older versions of the SDK (where those files were part of the AMP, which (I think) was the reason for this to work).

ardolecommented, Sep 19, 2018

Hi @gehriga @binduwavell,

Same thing for me, with SDK 3.0.1, Alfresco 5.2.1.

The resources (JS) are in src/main/resources/META-INF/resources (trying in web folder with the same result), disable-resource-caching is true. mvn compile alfresco:refresh-share does not work with and without HotSwapAgent.

Any news from your side ?

Read more comments on GitHub >

github_iconTop Results From Across the Web

One switch stopped working on hot swap pcb. What should I try?
Pull the switch, and check the contact, inside the hotswap socket. They're basically like a tiny copper leaf, and they're flexible. Sometimes, ...
Read more >
fix hot swap - YouTube
fix hot swap. 17K views 3 years ago. KBD fans. KBD fans. 7.86K subscribers. Subscribe. 140. I like this. I dislike this. Share....
Read more >
Hot code swap is not working, why? - java - Stack Overflow
You would have to use hot swap proxy for swapping classes in EE container like jRebel. Check it out. Share. Share a link...
Read more >
HotSwap not working anymore | TrueNAS Community
Cadet. Hi there, I was wondering if there's any possibility to find out why hot swapping of harddrives isn't working anymore. I had...
Read more >
Reliability Issues for Hot Swappable Devices - EE Times
This article describes methods of solving both of these problems without the need for tranzorbs, overrating of power devices and short pins, by...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found