Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

ImportError: No module named binstar_client.scripts.cli

See original GitHub issue

Issue Description

Traceback (most recent call last):
  File "/usr/bin/binstar", line 4, in <module>
    from binstar_client.scripts.cli import main
ImportError: No module named binstar_client.scripts.cli

binstar 0.4.4 py27_1

Issue Analytics

  • State:closed
  • Created 9 years ago
  • Comments:9 (4 by maintainers)

github_iconTop GitHub Comments

chmodssscommented, Feb 4, 2016

I had the same error. Since, binstar is changed into anaconda-client, removing and re-installing anaconda-client, fixed the error for me.

asmeurercommented, Feb 11, 2014

conda remove;conda install is not a good way to re-install a troublesome package. Use conda install -f instead. This will force re-extract the package from the tarball.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Python error "ImportError: No module named" - Stack Overflow
Using PyCharm (part of the JetBrains suite) you need to define your script directory as Source:
Read more >
How to Fix ModuleNotFoundError and ImportError
Module imports can certainly frustrate people and especially those who are fairly new ... import aModuleNotFoundError: No module named 'a'.
Read more >
Script input Error - No module named splunklib.client
Solved: I am trying to index data from my python script. Everything set up correctly but I still don't see data coming in....
Read more >
Error: ImportError: No module named arcpy - Esri Support
Solution or Workaround. Ensure that the following locations are specified in the Server10.3.pth file (the version of ArcGIS Server determines ...
Read more >
Resolve "ImportError: No module named" in AWS Glue
When I try to import extra modules or packages using the AWS Glue Python shell, I get an "ImportError: No module named" response....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found