Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

conda tab doesn't work

See original GitHub issue

I just recorded a screencast of this problem:

In short:

  1. I created a conda env with:

    conda create -n testaen -c anaconda-nb-extensions -c r -c wakari nb_conda nb_conda_kernels r-essentials
  2. I entered that conda environment to run conda:

    source activate testaen
    jupyter notebook
  3. I started Jupyter and then tried to go to the Conda tab. I get the error shown in the 2 minute video above. The full log from the start of Jupyter is below:

$ jupyter notebook
[W 16:03:52.822 NotebookApp] Widgets are unavailable. Please install widgetsnbextension or ipywidgets 4.0
[I 16:03:52.832 NotebookApp] The port 8888 is already in use, trying another port.
[I 16:03:52.843 NotebookApp] Serving notebooks from local directory: /Users/ijstokes/code/aetrial/files/assets
[I 16:03:52.843 NotebookApp] 0 active kernels 
[I 16:03:52.843 NotebookApp] The Jupyter Notebook is running at: http://localhost:8889/
[I 16:03:52.843 NotebookApp] Use Control-C to stop this server and shut down all kernels (twice to skip confirmation).
[W 16:04:04.164 NotebookApp] Notebook simon/Flight delays R model.ipynb is not trusted
[I 16:04:04.921 NotebookApp] Kernel started: d0272f60-34bb-4fc8-b256-c51a25cf23a2
[W 16:04:05.358 NotebookApp] 404 GET /nbextensions/widgets/notebook/js/extension.js?v=20160418160352 (::1) 17.64ms referer=http://localhost:8889/notebooks/simon/Flight%20delays%20R%20model.ipynb
[I 16:06:04.761 NotebookApp] Saving file at /simon/Flight delays R model.ipynb
[W 16:06:04.762 NotebookApp] Saving untrusted notebook simon/Flight delays R model.ipynb
[W 16:06:44.134 NotebookApp] 404 GET /environments?_=1461009837436 (::1) 2.19ms referer=http://localhost:8889/tree/simon
[W 16:06:44.136 NotebookApp] 404 GET /packages/available?_=1461009837437 (::1) 0.93ms referer=http://localhost:8889/tree/simon
[W 16:07:08.330 NotebookApp] 404 GET /environments?_=1461009837441 (::1) 1.39ms referer=http://localhost:8889/tree/simon
[W 16:07:08.332 NotebookApp] 404 GET /packages/available?_=1461009837442 (::1) 1.39ms referer=http://localhost:8889/tree/simon

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:27 (21 by maintainers)

github_iconTop GitHub Comments

dankrausecommented, Aug 15, 2016

I ran into this issue myself (404s on /environments and /packages) on a fresh install. Here’s the output of jupyter serverextension list

config dir: /home/py/anaconda3/etc/jupyter
    nbpresent  enabled 
    - Validating...
      nbpresent  OK
    nb_conda  enabled 
    - Validating...
      nb_conda  OK
    nb_anacondacloud  enabled 
    - Validating...
      nb_anacondacloud  OK

I then ran the following commands:

jupyter serverextension disable nb_conda
jupyter serverextension enable nb_conda

Before running these commands, ~/.jupyter/jupyter_notebook_config.json did not exist. After these operations, it did exist, with the following contents:

  "NotebookApp": {
    "nbserver_extensions": {
      "nb_conda": true

This caused nb_conda to start working properly. When I move that file out of the way by renaming it, nb_conda starts failing again, even though the output of jupyter serverextension list is unchanged.

damianavilacommented, Apr 12, 2017

The original issue seems related with some failures when you install nb_conda alongside with some jupyter-contrib extensions. That will be further researched on #41

There is second issue related with some configs in the user space conflicting with the config we use at the sys-prefix… that could be investigated later in the following issue: #49

Finally, there is some issue related with jupyterhub, that will follow up in the this issue: #50

Closing this one now.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Enabling tab completion - Conda
Open a new terminal window or an Anaconda Prompt. · Type: conda ins , and then press the Tab key. The command completes...
Read more >
TAB completion does not work in Jupyter Notebook but fine in ...
I had the same issue when I was using miniconda, I switched to anaconda and that seems to have solved the ...
Read more >
Troubleshooting - Anaconda Documentation
You can do a few things to solve this. They are listed from most straightforward to most complex. ... Uninstall Anaconda and then...
Read more >
Is there tab completion for Anaconda on Windows? - Super User
Even the official manual mentions only Bash and zsh. To be sure that it doesn't work for Windows 10, I've done what was...
Read more >
Jupyter notebook browser page not loading
However, when I try to open jupyter in a browser tab I cannot connect, ... anaconda and jupyter notebook, but the notebook still...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found