Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

godaddy: test suite is failing, delete throws HTTP 422

See original GitHub issue
  • Reported on the Let’s Encrypt forums.
  • Test suite fails against provided OTE endpoint and credentials: tests/providers/ .......ssFFFsssFsssFFsF.F.FF
  • Confirmed by me against a live domain with live credentials, fails in same way as forum post:
Arguments: Namespace(action='delete', auth_key='<redacted>', auth_secret='<redacted>', content='abcdef', delegated=None, domain='', identifier=None, log_level='DEBUG', name='', priority=None, provider_name='godaddy', ttl=None, type='TXT')
Starting new HTTPS connection (1): "GET /v1/domains/ HTTP/1.1" 200 212
Starting new HTTPS connection (1): "GET /v1/domains/ HTTP/1.1" 200 251
Starting new HTTPS connection (1): "PUT /v1/domains/ HTTP/1.1" 422 275
Traceback (most recent call last):
  File "/home/alex/devel/venv-lexicon/bin/lexicon", line 11, in <module>
  File "/home/alex/devel/venv-lexicon/local/lib/python2.7/site-packages/lexicon/", line 72, in main
  File "/home/alex/devel/venv-lexicon/local/lib/python2.7/site-packages/lexicon/", line 50, in execute
    return self.provider.delete_record(self.options.get('identifier'), self.options.get('type'), self.options.get('name'), self.options.get('content'))
  File "/home/alex/devel/venv-lexicon/local/lib/python2.7/site-packages/lexicon/providers/", line 106, in delete_record
    self._put('/domains/{0}/records'.format(domain), to_insert)
  File "/home/alex/devel/venv-lexicon/local/lib/python2.7/site-packages/lexicon/providers/", line 79, in _put
    return self._request('PUT', url, data=data, query_params=query_params)
  File "/home/alex/devel/venv-lexicon/local/lib/python2.7/site-packages/lexicon/providers/", line 130, in _request
  File "/home/alex/devel/venv-lexicon/local/lib/python2.7/site-packages/requests/", line 935, in raise_for_status
    raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 422 Client Error: Unprocessable Entity for url:

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:11 (6 by maintainers)

github_iconTop GitHub Comments

adferrandcommented, Jun 5, 2018

OK I took the time to work on godaddy provider implementation. I think I haved fixed all issues, PR will be submitted tomorrow.

alexzorincommented, Jun 10, 2018

Appears to be fixed by #241 , thanks!

Read more comments on GitHub >

github_iconTop Results From Across the Web

Solved Godaddy Domain API error 422 - Cloudron Forum
I'm currently using Wildcard config as a workaround but this is not ideal as I have many (sub)domains. The exact error code is....
Read more >
How To Fix the HTTP 422 Error - Kinsta
Error 422 is an HTTP code that tells you that the server can't process your request, although it understands it. The full name...
Read more >
Error 422 When Using Powershell to Update DNS Records on ...
I am able to succesfully update when using the script found at when run through cygwin. However I am trying to ...
Read more >
GoDaddy charged for a cancelled domain, refused refund, re ...
EDIT: It gets worse. I just tried to delete the payment method from my GoDaddy account. Not allowed! They insist that you must...
Read more >
422 Unprocessable Entity - HTTP - MDN Web Docs
The HyperText Transfer Protocol (HTTP) 422 Unprocessable Entity response status code indicates that the server understands the content type ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found