Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Task "sass:dev" not found.

See original GitHub issue
 "name": "electron-release-server",
  "version": "1.4.2",

npm start

Task “sass:dev” not found.

debug: -------------------------------------------------------
debug: :: Thu Dec 15 2016 09:54:00 GMT+0800 (CST)

debug: Environment : development
debug: Port        : 1337
debug: -------------------------------------------------------

error: ** Grunt :: An error occurred. **
Aborted due to warnings.
Running "wiredep:task" (wiredep) task
Warning: Task "sass:dev" not found.

error: Looks like a Grunt error occurred--
error: Please fix it, then **restart Sails** to continue running tasks (e.g. watching for changes in assets)
error: Or if you're stuck, check out the troubleshooting tips below.

error: Troubleshooting tips:
error:  *-> Are "grunt" and related grunt task modules installed locally?  Run `npm install` if you're not sure.
error:  *-> You might have a malformed LESS, SASS, CoffeeScript file, etc.
error:  *-> Or maybe you don't have permissions to access the `.tmp` directory?
error:      e.g., `/home/github/electron-release-server/.tmp` ?
error:      If you think this might be the case, try running:
error:      sudo chown -R YOUR_COMPUTER_USER_NAME /home/github/electron-release-server/.tmp

Issue Analytics

  • State:closed
  • Created 7 years ago
  • Comments:13 (6 by maintainers)

github_iconTop GitHub Comments

johniwcommented, Jan 6, 2017

For those people whom reinstalling didn’t do the trick, try running npm rebuild node-sass . As detailed here, rebuilding fixed the issue :

zjfjiayoucommented, May 21, 2017

I use rebuild node - sass and solved the problem,ths ArekSredzki

Read more comments on GitHub >

github_iconTop Results From Across the Web

Tasks and sub-tasks not found - Stack Overflow
And when I run grunt sass:dev , it always returns me Warning: Task "sass:dev" not found. Use --force to continue. As I'm starting ......
Read more >
grunt build does not work for SGJC - Salesforce Stack Exchange
One of the solution is to go to Project - Clean... in UX Studio or upload the built version in any other way....
Read more >
Setting up Sass with Grunt - Culttt
So whenever a file under the scss directory is updated, run the sass:dev task. To keep things relatively simply I'll only install Sass...
Read more >
Task Runner not working using gulp tasks when this using a ...
Hello everyone, I'm working with Visual Studio 2017, where I need to run gulp tasks for the management of my website files. My...
Read more >
Error: File to import not found or unreadable: ~bootstrap/scss ...
Command: grunt After composer require drupal/mdbs, grunt error; Running "sass:dev" (sass) task Fatal error: Error: File to import not found ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found