Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Lightzone cannot find native libraries LCJPEg and LCLENSFUN

See original GitHub issue

Hi there,

good to see that Lightzone development is going on! However, with version 4.24 I run into some issues. When I invoke Lightzone from xterm window, I get the following error messages:

**Couldn't link with native library: "LCJPEG**
/usr/libexec/lightzone/ /usr/lib64/ version `LIBJPEG_8.0' not found (required by /usr/libexec/lightzone/
**Couldn't link with native library: "LCLENSFUN**
/usr/libexec/lightzone/ Cannot open shared object file: File or directory not found

This is on Slackware Linux, stable version (15.0) with all patches and updates until today applied. I tried this with Lightzone 4.24. It looks very similar to the issue that seemed to be present only in MacOS and was fixed in version 4.25 (the Mac only release).

I’d greatly appreciate, if you could look into this and (hopefully) also fix it or provide some workaround. Thanks in advance!

Best regards


Issue Analytics

  • State:closed
  • Created a year ago
  • Comments:8

github_iconTop GitHub Comments

F9Racecommented, Oct 18, 2022

@ktgw0316 Fantastic, THANKS A LOT in BIG letters! That was indeed it. I uninstalled the package, recursively removed /usr/libexec/lightzone/, re-installed the package generated with your SlackBuild script, and all is good! A fully localised (German, in my case) Lightzone starts up, and reads in the last directory with RAW images that I had been working with a previous version. No complaints about missing libraries. I can hardly express, how much I appreciate your support. You took a lot of effort, even installing my distro, finding out, how SlackBuild scripts work, writing one yourself, and helping me in using it correctly. I really appreciate that! So, this ticket can be closed, now, I guess. 😃

ktgw0316commented, Oct 17, 2022

Regarding the commands, I think all of them, except wget, should be executed as root, not just the last two.

You are right. 👍

java.lang.UnsatisfiedLinkError: no DCRaw in java.library.path: /usr/libexec/lightzone

I guess you haven’t uninstalled your older lightzone package, which contains the /usr/libexec/lightzone/, before you installed newer package. If that directory exists, correct libraries under /usr/lib64/lightzone/ cannot be found. cf. /usr/bin/lightzone (line 26-32).

Now, JAI and FASTJAI are indeed not installed in my system, just because I don’t know which Slackware packages are needed.

You need not install any additional packages, since there already exist,, libFASTJAI, etc. in /usr/lib64/lightzone/.

Read more comments on GitHub >

github_iconTop Results From Across the Web

System.loadLibrary(...) couldn't find native library in my case
In my new Android project I created a folder libs/armeabi/ and put there. There is no jni/ folder. My testing device has...
Read more >
LightZone - githubmemory
LightZone repo issues. ... Lightzone cannot find native libraries LCJPEg and LCLENSFUN. andrewk8. andrewk8 OPEN · Updated 2 months ago ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found