Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Manually running server on Windows 7 error

See original GitHub issue

Version: 4.1.17 OS: Windows 7, 64-bit Browser: Chrome 71

When I run the server manually and a new client connects, I see this error:

C:\Users\admin\Documents\openvpn-status-4.1.17>node server.js
(node:4628) UnhandledPromiseRejectionWarning: TypeError: Cannot read property 'C
lient ID' of undefined
    at clientToEntry (C:\Users\admin\Documents\openvpn-status-4.1.17\server.js:7
    at (C:\Users\admin\Documents\openvpn-status-4.1.17\server.js:16
    at emitOne (events.js:116:13)
    at client.emit (events.js:211:7)
    at getClients.then (C:\Users\admin\Documents\openvpn-status-4.1.17\openvpn.j
    at <anonymous>
    at process._tickCallback (internal/process/next_tick.js:188:7)
(node:4628) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This
error originated either by throwing inside of an async function without a catch
block, or by rejecting a promise which was not handled with .catch(). (rejection
 id: 1)
(node:4628) [DEP0018] DeprecationWarning: Unhandled promise rejections are depre
cated. In the future, promise rejections that are not handled will terminate the
 Node.js process with a non-zero exit code.

The new client does not show in the webpage. Note: this is the first time using the new management port instead of the connect/disconnect scripts in version 4.0.25.

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:13 (13 by maintainers)

github_iconTop GitHub Comments

xinthosecommented, Feb 22, 2019

Everything works fine on Windows Server 2012 R2 and node 10.15.1 from master branch 7ceaa1de40b93cb248b1b64e3a85b5842d36807b

xinthosecommented, Jan 3, 2019

OK. So the problem is that client is undefined but data is not. The problem is probably with string parsing then. I would imagine the OpenVPN management port is OS agnostic. Version 4.0.25 worked fine for me. I will see what I can do. Thank you for your help.

Read more comments on GitHub >

github_iconTop Results From Across the Web

"Cannot connect the computer to the server" error message ...
Cannot connect the computer to the server because either another software installation is in progress or, the computer has a restart pending.
Read more >
Windows 7 Update Server is not running. How do I start it?
I'm running Windows 7 Professional on a Pentium 4 3.0 GHz processor. ... I tried to do a manual request for updates and...
Read more >
Fix Windows Update errors by using the DISM or System ...
To do this, open the Start menu or Start screen, type Command Prompt, right-click Command Prompt, and then select Run as administrator. If...
Read more >
How to troubleshoot Windows Installer errors - Microsoft Support
Right-click Windows Installer, and then click Properties. If the Startup type box is set to Disabled, change it to Manual.
Read more >
Error 1079 when services fail to start - Windows Server
Fixes error 1079 that occurs when some services fail to start on a computer that's running Windows 7.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found