Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Can't use CDK to deploy to govcloud

See original GitHub issue

When running cdk deploy from my command line when my AWS_PROFILE is set to my govcloud credentials. I get an error: Need to perform AWS calls for account unknown-account, but no credentials found. Tried: default credentials.. When I switch to a profile that is for a non-gov region, then it works just fine.

I have Administrator permissions in both accounts right now.

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:14 (7 by maintainers)

github_iconTop GitHub Comments

RafalWilinskicommented, Jan 31, 2019

I had similar issue and it seems that the problem was corrupted ~/.aws/config file. After cleaning it, everything went well.

mikedercommented, Feb 1, 2019

Ah, @rix0rrr you’re right. I just took a look at my original ~/.aws/config and had both a [default] and a [profile default] block. I removed the [profile default] entry and reverted my credentials file to my master account credentials and CDK seems to be working as expected.

Thanks for reference on the auth mechanisms too 👍

Read more comments on GitHub >

github_iconTop Results From Across the Web

How can I use aws cdk's 'cdk synth' command to use govcloud ...
I ran this command. cdk synth --profile default. My profile consists of my govcloud creds and region.
Read more >
Services in AWS GovCloud (US) Regions
Describes the differences between the AWS GovCloud (US) Regions and the standard AWS Region US East (N. Virginia).
Read more >
aws-cdk | Yarn - Package Manager
The AWS Cloud Development Kit (AWS CDK) is an open-source software development framework to define cloud infrastructure in code and provision it through...
Read more >
Building and governing multi-accounts using AWS Control ...
Many AWS customers are implementing multi-account strategies in order to more easily manage their cloud infrastructure and improve their ...
Read more >
Resolve "Invalid principal in policy" error in Amazon S3
I'm trying to add or edit the bucket policy of my Amazon Simple Storage Service (Amazon S3) bucket using the console. However, I'm...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found