Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error raised when creating new HttpTrigger function on CLI v4

See original GitHub issue

As per @anthonychu’s blog post - - I have updated my v4 core tools.

On creating a new HttpTrigger function I receive the following error:

The post action 84c0da21-51c8-4541-9940-6ca19af04ee6 is not supported.
Description: Opens the function class file in the editor

Steps to reproduce

  1. cd c:\temp
  2. mkdir functions8
  3. cd functions8
  4. func init --worker-runtime dotnetIsolated
  5. func new
  6. select HttpTrigger from option list
  7. Add name of function eg. MyFunction


C:\Temp\functions8> func new
Use the up/down arrow keys to select a template:Function name: MyFunction
The post action 84c0da21-51c8-4541-9940-6ca19af04ee6 is not supported.
Description: Opens the function class file in the editor

The function "MyFunction" was created successfully from the "HttpTrigger" template.

SDKs installed

C:\Temp\functions8> dotnet --list-sdks 2.2.401 [C:\Program Files\dotnet\sdk] 3.1.301 [C:\Program Files\dotnet\sdk] 3.1.406 [C:\Program Files\dotnet\sdk] 5.0.103 [C:\Program Files\dotnet\sdk] 5.0.401 [C:\Program Files\dotnet\sdk] 6.0.100-preview.6.21355.2 [C:\Program Files\dotnet\sdk] 6.0.100-rc.1.21458.32 [C:\Program Files\dotnet\sdk]

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:8 (5 by maintainers)

github_iconTop GitHub Comments

soninarencommented, Oct 7, 2021

Interestingly, well I thought it was, I just ran the same command in the developer terminal inside Visual Studio 2022 Preview 4.1 half expecting the post action to execute and open the newly creating function in the IDE instance but the same error occurred.

This is expected. If the command was executed via dotnet cli, regardless of the kind of terminal window.

The only time this post action actually takes effect is when it is run via the VS UI. So if you add a function to your project via VS, right click csproj -> Add a function -> (follow wizard until function creation). This is when you would see the newly created function in editor.

anthonychucommented, Sep 25, 2021

Thanks for reporting. @brettsam @soninaren can we suppress this message?

Read more comments on GitHub >

github_iconTop Results From Across the Web

No HTTP triggers found · Issue #1774 · microsoft/Oryx
Experienced the problem while trying to deploy an HTTP request-triggered function to azure. If your repo is publicly available please share its ...
Read more >
trigger Python script containing Azure CLI commands
I tried to create a simple Azure Function with HttpTrigger to invoke Azure CLI ... elif cli.result.error: raise cli.result.error return True.
Read more >
Python developer reference for Azure Functions
This guide is an introduction to developing Azure Functions by using Python. The article assumes that you've already read the Azure ...
Read more >
Azure Functions CLI Failing After Preview Install - Adam Storr
I would select a new Http Trigger from the options and give it a name as required. But then after a few seconds...
Read more >
Troubleshoot Cloud Functions
For HTTP trigger-based functions, have the client implement exponential backoff and retries for requests that must not be dropped.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found