Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

[BUG] Unable to get Telemetry for device using default event hub

See original GitHub issue

I’m new into looking at the Azure IoT and was attempting to follow the guide here. I have created my IoT Hub and downloaded the latest version of IoT Explorer, however I was having trouble viewing the telemetry in IoT Explorer. I kept getting an issue indicating it can’t connect to the event hub which I’m just using the default built it. I’ve downgraded to each version until I got to v0.14.12 before it started working for me.

Steps to reproduce:

  1. Create a free tier of IoT Hub in Azure Portal
  2. Download any version of IoT Explorer from v0.14.13 - v0.15.0
  3. Connect IoT Explorer using the connection string for iothubowner
  4. Add a device with Test001 as the deviceId
  5. Go to Telemetry
  6. Click Start See: Error Expect: Connect and see telemetry like in v0.14.12

It is possible I am doing something wrong but I just followed the guide and it didn’t work.

Failed to start monitoring device telemetry: Error: "The messaging entity 'sb://$management' could not be found. To know more visit TrackingId:3ef1fdc8-301b-4b12-bb34-4d269c692581_G6,$management, Timestamp:2022-09-16T14:10:51"

Issue Analytics

  • State:closed
  • Created a year ago
  • Comments:16 (7 by maintainers)

github_iconTop GitHub Comments

YingXuecommented, Nov 8, 2022 has addressed the issue. Event hub’s sdk fixes has been incorporated.

YingXuecommented, Nov 4, 2022

Hi, we use their sample in this app to convert iot hub connection strings (that users use to login to) to event hub connection string, and pull telemetry from event hub. I’ve tried their latest sample, but the same error repros. Our team is following up with them, but it does not look this issue has been addressed. I will follow up again.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Azure IoT Explorer: Unable to get Telemetry for device using ...
Azure IoT Explorer: Unable to get Telemetry for device using default event hub. I'm new into looking at the Azure IoT and was...
Read more >
[BUG] Unable to start running telemetry via v0.14.13 #541
Instructions: Please turn on 'Use built-in event hub' toggle and fill in the two values of the event hub, and then start the...
Read more >
Troubleshooting - F5 Cloud Docs
By default, BIG-IP Telemetry Streaming compresses data before sending it to Splunk. Depending on the events per second rate (events from the Event...
Read more >
Error while trying to connect to azure event hub using amqp
I'm running this code on macosx using python-qpid-proton (0.10) installed using pip. but i can't get any messages of the event-hub I do...
Read more >
Azure Event Hubs and its Complete Overview - Serverless360
Azure Event Hubs monitoring and management challenges are solved by using Serverless360. Read to know more about the complete overview of Azure Event...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found