Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Dockle scan fails due to invalid username/password combo

See original GitHub issue

Trivy check runs successfully according to log

Scanning for vulnerabilities...
No vulnerabilities were detected in the container image

But after Dockle initializes we get this message:

Scanning for CIS and best practice violations...
Error: FATAL	unable to initialize a image struct: failed to initialize source: unable to retrieve auth token: invalid username/password: unauthorized: authentication required, visit for more information.
Error: An error occurred while scanning the container image for best practice violations

The action seems to be taking the credentials we provided

Run Azure/container-scan@v0
    image-name: ***/search-training-index:aa12c0d5170e523d92ddf29cfc51e54a7a7c19ea
    username: ***
    password: ***
    severity-threshold: HIGH
    token: ***
    run-quality-checks: true
    AZURE_WEBAPP_NAME: search-training-index

We know our credentials are right, because are being used by other actions.

Any idea of what’s going on? What i’m missing?

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:1
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

tomoyamachicommented, Mar 2, 2021

@JeffreyArt1 Thank you for the report. That was a Dockle’s bug and I fixed it. For details, see this issue.

shigupt202commented, Feb 26, 2021

As a workaround, you can pull the ACR image before running the container-scan action.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Solved: 401 - Invalid username/password combo. - ServiceNow
Surely the error message should be an indication: 401 - Invalid username/password combo. Have you verified the credentials for your profile are correct?...
Read more >
Invalid username/password or database/scan listener not up
11.2 RAC DBconsole Creation Fails With Error: "Invalid username/password or database/scan listener not up" (Doc ID 1276751.1).
Read more >
password) When Failing to Login with an LDAP User Account
Issue. LDAP users are unable to login into with the error message "error|WARNING|0|Invalid username/password combination for User < ...
Read more >
Invalid username or password on agent install for N-sight RMM
Invalid username or password on agent install for N-sight RMM. N-sight RMM Troubleshooting · Take Control (TeamViewer) is getting a 5-minute ...
Read more >
Invalid username/password combo (HTTP 401/403)
If the population has failed and the log shows an HTTP 401 or 403 status error message related to the wrong user and...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found