Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Cannot start the workflow designer in VS Code

See original GitHub issue

Describe the Bug

I’m developing Logic Apps in VS Code on a Mac. Starting today I cannot load the workflow designer.

When I try to open a workflow using the context menu “Open in Designer” I get the usual message "Starting workflow design time api. It might take a few seconds.". In the output window I can see the following:

[2023-01-31T13:27:44.554Z] A host error has occurred during startup operation 'c2a7523a-39b6-4371-b479-365d12600950'.
[2023-01-31T13:27:44.554Z] Microsoft.WindowsAzure.ResourceStack: Unable to load shared library 'advapi32.dll' or one of its dependencies. In order to help diagnose loading problems, consider setting the DYLD_PRINT_LIBRARIES environment variable: dlopen(libadvapi32.dll, 0x0001): tried: 'libadvapi32.dll' (no such file), '/System/Volumes/Preboot/Cryptexes/OSlibadvapi32.dll' (no such file), '/usr/lib/libadvapi32.dll' (no such file, not in dyld cache), 'libadvapi32.dll' (no such file), '/usr/local/lib/libadvapi32.dll' (no such file), '/usr/lib/libadvapi32.dll' (no such file, not in dyld cache).
Value cannot be null. (Parameter 'provider')
2:41:46 PM: Error: connect ECONNREFUSED
2:42:44 PM: Running command: "func host start --port 8000"... 

I can also see that a func process is being started and then quickly terminated when looking in the Activity Monitor.

This has been reproduced on several MacBooks, using Intel (Core i7) as well as Apple (M1 Pro) silicon. Same result.

Yesterday, January 30th, this was working fine. Today on Jan 31, it’s not.

Plan Type


Steps to Reproduce the Bug or Issue

  1. Open any logic app standard project
  2. Try to open a workflow by right-clicking on a “workflow.json” file and then select “Open in Designer”
  3. View output pane (Shift+CMD+U on Mac)

Workflow JSON

  "definition": {
    "$schema": "",
    "actions": {},
    "contentVersion": "",
    "outputs": {},
    "triggers": {}
  "kind": "Stateful"

Screenshots or Videos

Screenshot 2023-01-31 at 15 11 56

Additional context

No response

AB#16959559 Relates #722

Issue Analytics

  • State:closed
  • Created 8 months ago
  • Comments:17

github_iconTop GitHub Comments

axiomitdavidcommented, Apr 14, 2023

I’m trying to specify

“version”: “2.0”, “extensionBundle”: { “id”: “Microsoft.Azure.Functions.ExtensionBundle.Workflows”, “version”: “[1.*, 1.8.9)”

But this results in the broken 1.3.7 extension being downloaded.

I’ve reverted to 1.2.18 as per the original workaround for this issue. Which is working.

For those just stumbling upon this issue:

You need to update host.json in both workflow-designtime and in the project level host.json


“extensionBundle”: { “id”: “Microsoft.Azure.Functions.ExtensionBundle.Workflows”, “version”: “[1.*, 2…0.0)” },


“extensionBundle”: { “id”: “Microsoft.Azure.Functions.ExtensionBundle.Workflows”, “version”: “[1.*, 1.2.18)” },

This should allow editing and running your workflows locally while the issue is worked on.

ccastrotrejocommented, Feb 2, 2023

Hi all, thanks for raising this issue and for collaborating on the thread. I am able to repro the issue and will update you as soon as this is fixed. Please keep using the workaround stated above

Read more comments on GitHub >

github_iconTop Results From Across the Web

workflow designer not starting in vscode
When I click on Open Designer context menu for workflow.json it fails to start designer and the output is below 5:45:52 PM: Running...
Read more >
Logic App (standard): VS Code can't open workflow in ...
Update : Found a workaround. If we open VS code with start folder as nested folder, the designer works then.
Read more >
Workflow design time could not be started - Logic App Standard
Workflow design time could not be started, error while switching from code view to designer view in logic app standard.
Read more >
Not able to debug Azure Logic App workflow using Visual ...
Workflow run history could not be loaded. Error: 'Could not establish connection to the host. Run your function project to view the run...
Read more >
Workflow Designer in Visual Studio now crashing - can't ...
I have VisualStudio 2015, and until very recently, the Worflow Designer worked, I could create workflows in VS. I'm not sure what changed,...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found