Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

BUG: Unable to retrieve MagicMirror modules. Is your internet connection up?

See original GitHub issue

Describe the Bug

Is this an issue with the CLI or GUI? mmpm doesn’t start

Is this something that should be put in the Wiki? if it’s not a weird bug on my system, maybe enhancing the setup guide would be a nice idea.

A clear and concise description of what the bug is. When installing mmpm via python3 on a Ubuntu 20.04.01 LTS with a MagicMirror via Docker-Compose, the mmpm won’t start after installing and configuring.

To Reproduce Steps to reproduce the behavior:

  1. Install as told in the guidelines
  2. Configuring with mmpm --guided-setup
  3. Try to do something (p.e. mmpm log)
  4. See the error

Expected behavior Able to use the software

Operating System, Python3 Version, and Web Browser
(Please complete the following information)

MMPM Environment Settings

  • output from mmpm env
      • Initializing MagicMirror 3rd party packages database ✘ FATAL: Unable to retrieve MagicMirror modules. Is your internet connection up?

MMPM Log Files

  • Attach the file produced Download MMPM log files within the Control Center of the GUI or from the mmpm log --zip
    • unable to produce. Same error.
    • Content of mmpm-cli-interface.log is repeatedly:
2020-10-26 20:15:12,804.804 CRITICAL utils - fatal_msg: Unable to retrieve MagicMirror modules. Is your internet connection up?
Unable to retrieve MagicMirror modules. Is your internet connection up?

MagicMirror Config

  • your MagicMirror config.js
    • not existing

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:7 (2 by maintainers)

github_iconTop GitHub Comments

Bee-Marcommented, Oct 29, 2020

This is most likely an issue with the MagicMirror 3rd party modules page. Someone probably altered the markdown/html which caused parsing to fail. I’ll have to look into the structure of the page

td00commented, Nov 18, 2020

It seems, like there’s was a problem using a previous installed MagicMirror version. I’ve removed the MagicMirror Version installed & installed a new Version via mmpm. After the installation via mmpm & restoring the config & modules, everything works fine.

It seems like the error, produced in this constellation was just misleading. Not quite sure how to reproduce this error. Tried it on a similar machine, with a backup from the previous not working “prod” system and there it worked like a charm.

Seems to be a bug on my system.

Thanks for looking into it.

cheers 😃

Read more comments on GitHub >

github_iconTop Results From Across the Web

BUG - after 3/4 days - MagicMirror Forum
Hello, I installed magicMirror in my Raspberry pi 3 and i have successfully added my module. now, the software stop working after three/four ......
Read more >
Network connection problems : r/MagicMirror - Reddit
I've got an issue where everything runs fine....when it runs. On a reboot I see things like this in the error logs... fatal:...
Read more >
IoT Smart Mirror with Auth0, Raspberry Pi, React, and Node.js
Smart mirror powered by Auth0, NodeJS, React, a Raspberry Pi3, and a two-way mirror.
Read more >
MMM Hotword crashing - magic mirror - Stack Overflow
I've encountered this problem using Assistant Relay in a Raspberry Pi and the problem is the same, seems like a bug or issue...
Read more >
Some of the Best Magic Mirror 2 Modules - How to Build
Your browser can't play this video. Learn more. Switch camera.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found