Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Opengl crash at startup after 3.2.0 update

See original GitHub issue


After trying to update FamiStudio from version 3.1.1 to 3.2.0, the software crashes on my machine at startup with the error “The specified window isn’t an OpenGL window” (see attached image). Version 3.2.1 also crashes.


Neither the installer version nor the portable version works, even after a clean install. I also tried to update my graphics card drivers to no avail. I also tried to build the program from source and running it and the application crashes with the following callstack :

 	[External Code]	
>	FamiStudio.exe!FamiStudio.GLForm.OnHandleCreated(System.EventArgs e) Line 69	C#
 	FamiStudio.exe!FamiStudio.FamiStudioForm.OnHandleCreated(System.EventArgs e) Line 422	C#
 	[External Code]	
 	FamiStudio.exe!FamiStudio.FamiStudioForm.WndProc(ref System.Windows.Forms.Message m) Line 302	C#
 	[External Code]	
 	FamiStudio.exe!FamiStudio.FamiStudioForm.Run() Line 440	C#
 	FamiStudio.exe!FamiStudio.FamiStudio.Run() Line 594	C#
 	FamiStudio.exe!FamiStudio.Program.Main(string[] args) Line 76	C#

A clean install of version 3.1.1 still launches perfectly.

After running a git bisect on my machine I have found that the crash appears after this commit if that can help.

I remain available if you have any remaining questions.

Thanks !

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:13 (8 by maintainers)

github_iconTop GitHub Comments

BleuBleucommented, Dec 19, 2021

@EspeuteClement That’s great!!!

EspeuteClementcommented, Dec 19, 2021

I can confirm that was the issue on my computer. I had a sdl2.dll fiile that was discoverable on my system (protip : to seach those one can type where sdl2.dll in a terminal to see where windows would find that dll if it’s can find it via PATH). Removing that dll allows me to launch fami studio again, horray !

Read more comments on GitHub >

github_iconTop Results From Across the Web

Crashes on launch (OpenGL error) ever since the ...
I'm playing inside a Windows 11 virtual machine, but the game worked fine until the multiplayer update. Now it's complaining about having ...
Read more >
AE crashes on startup; Gives OpenGL error
Start by checking your system event viewer, your device manager and Windows Update. I'm pretty sure something is flagged there.
Read more >
How to Fix OpenGL Error (for Old PC or No Graphic Card)
How to Fix OpenGL Error (for Old PC or No Graphic Card) - Complete Solution. Pretty much any OpenGL error is caused by...
Read more >
OpenGL Driver Version?
Hi,. I've browsed through similar questions about updating OpenGL Drivers and the capabilities of graphics cards and so on.
Read more >
Crash on startup :: Thinking with Time Machine Bugs and ...
Hi, when I start the game i get a crash. I appended the console log, feel free to contact me or respond to...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found