Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Electrs not finishing hashes

See original GitHub issue

Server is running on AWS - m5a.xlarge, 4 CPU, 16GB RAM, SSD 1000GB; OS - Ubuntu 18, installed bitcoin core, run it as bitcoind -daemon

GIT pulled Blockstream Electrs, switched to branch, started the cargo with cargo run --release --bin electrs -- -vvvv --daemon-dir ~/.bitcoin --http-addr

Electrs was doing hashes for a long-long time, and once I experienced Ubuntu’s error ‘too many files open’, but fixed it successfully. Now, the last time I launched, Electrs wrote me to console:

TRACE - skipping block 00000000000000d41e5497f984517d27afcd85dad80277e7b7856418a72c7f69
TRACE - skipping block 00000000000005c35bbadf1bced112ddd3fff6e8e63575832bb3ba788889c866
TRACE - skipping block 000000000000025925f4fab2b7ebe729e7c7d483098863a7cd31bc5c773a5098
TRACE - fetched 0 blocks
DEBUG - writing 0 rows to RocksDB { path: "./db/mainnet/newindex/history" }, flush=Disable
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00025.dat"
TRACE - parsing 134145055 bytes
TRACE - fetched 1383 blocks
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00026.dat"
TRACE - parsing 134182236 bytes
TRACE - fetched 1345 blocks
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00027.dat"
TRACE - parsing 134150531 bytes
TRACE - fetched 1290 blocks
TRACE - parsing 134189077 bytes
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00028.dat"
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00029.dat"
TRACE - parsing 134205573 bytes
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00030.dat"
DEBUG - writing 1979996 rows to RocksDB { path: "./db/mainnet/newindex/history" }, flush=Disable
TRACE - parsing 134113675 bytes
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00031.dat"
TRACE - fetched 1754 blocks
DEBUG - writing 1994881 rows to RocksDB { path: "./db/mainnet/newindex/history" }, flush=Disable
TRACE - parsing 134169607 bytes
TRACE - reading "/home/ubuntu/.bitcoin/blocks/blk00032.dat"
TRACE - fetched 1443 blocks

And that’s it. Nothing happens for more then an hour. I thought - “That’s it, everything works!”. Tried to make HTTP requests to server from internet (AWS SGs allow access to 3001 port) and from CLI to localhost itself, but receive this:

ubuntu@ip-172-61-11-224:~/electrs$ curl http://localhost:3001/blocks/tip/height
curl: (7) Failed to connect to localhost port 3001: Connection refused

And, BTW, when Electrs run, it starts some stats server on port :4224. When I do a request to localhost:4224 I receive some data, that means that this part of Electrs works, but not the Electrs itself.

I’ve made everything by instruction, step by step. I receive no errors. What else have I forgot?

Issue Analytics

  • State:open
  • Created 3 years ago
  • Comments:31

github_iconTop GitHub Comments

Netzhanghengcommented, Aug 8, 2020

@shesek I used an HDD before.

I will try agin with an SDD. Thank you.

mrtiggles5commented, Jun 7, 2022

@shesek When you say that the second stage reads heavily do you mean that it reads heavily from the block .dat files or from /txstore?

Read more comments on GitHub >

github_iconTop Results From Across the Web

Bug: electrs will not run on a big-endian machine. yes, i know ...
Describe the bug electrs effectively stops running after the following error message: thread 'bulk_index' panicked at 'index 2497364531 out ...
Read more >
JSONRPC reverse proxy to electrum server not working - Help
1. Output of caddy version: v2.6.2 h1:wKoFIxpmOJLGl3QXoo6PNbYvGW4xLEgo32GPBEjWL8o= 2. How I run Caddy: systemd a.
Read more >
Cryptocurrency Miners: Nvidia's Lite Hash Rate Limiter Did ...
Nvidia tried to discourage cryptocurrency miners from buying RTX 3000 graphics cards by handicapping their Ethereum mining capabilities.
Read more >
US, EU Hope to Hash Out Electric Vehicle Credit Tiff
Biden on December 1 said that the inflation bill's energy components were not meant to negatively impact Europe, and implied that there could ......
Read more >
How to Hot Knife Hash | Dockside Cannabis Blog
Hot knifing hash is a good way to consume cannabis when you don't have papers ... by resting the tips of the knives...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found