Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Completely stopped working

See original GitHub issue

Describe the bug

I’m not sure if this maybe an Octopus outage or what, but the integration currently isn’t loading at all for me, despite it working fine a few hours ago.

To Reproduce

Home Assistant Version


Integration Version


Home Assistant Logs `This error originated from a custom integration.

Logger: homeassistant.config_entries Source: custom_components/octopus_energy/ Integration: Octopus Energy (documentation, issues) First occurred: 17:54:11 (1 occurrences) Last logged: 17:54:11

Error setting up entry Octopus Energy for octopus_energy Traceback (most recent call last): File “/usr/src/homeassistant/homeassistant/”, line 372, in async_setup result = await component.async_setup_entry(hass, self) File “/config/custom_components/octopus_energy/”, line 41, in async_setup_entry await async_setup_dependencies(hass, File “/config/custom_components/octopus_energy/”, line 95, in async_setup_dependencies account_info = await client.async_get_account(config[CONFIG_MAIN_ACCOUNT_ID]) File “/config/custom_components/octopus_energy/”, line 152, in async_get_account “gas_meter_points”: list(map(lambda mp: { File “/config/custom_components/octopus_energy/”, line 157, in <lambda> “agreements”: list(map(lambda a: { File “/config/custom_components/octopus_energy/”, line 160, in <lambda> “tariff_code”: a[“tariff”][“tariffCode”] if “tariffCode” in a[“tariff”] else None, TypeError: argument of type ‘NoneType’ is not iterable `

Issue Analytics

  • State:closed
  • Created 9 months ago
  • Comments:10 (2 by maintainers)

github_iconTop GitHub Comments

lozzdcommented, Dec 12, 2022

Interesting - my 502 issue might be separate then. Mine started working on its own at 7:30 this morning… Presumably after someone at Octopus finally spotted an issue on their end. My rates are back.

BottlecapDavecommented, Dec 12, 2022

Glad to see this rectified itself. 500+ errors returned are on Octopus Energy’s side. I’ll see if I can improve the error messages to make this clearer.

Read more comments on GitHub >

github_iconTop Results From Across the Web

I still have a job, but I've completely stopped working!
But weeks go by, months go by, and we're still not working! What is the matter with us? And why has no one...
Read more >
[Solved!] My computer stopped working. How to fix it?
If the PC has suddenly stopped working · Case 1. Overheating due to a lack of ventilation. · Case 2. RAM is in...
Read more >
[Fixed] Application.exe has stopped working
When a program shuts down suddenly and an error message saying exe has stopped working pops up, you can try these 8 methods...
Read more >
suddenly stopped working or stopped working suddenly ?
A complete search of the internet has found these results: suddenly stopped working is the most popular phrase on the web. More popular!...
Read more >
Windows 10 start menu has suddenly stopped working
When was the last time it's working properly? ... Press Ctrl + Shift + Esc to open Task Manager. Select the Processes tab....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found