Code Style and NamingSee original GitHub issue
When we have the first integrated version skorch-api+dataset, we can make a pass over the code to enforce some more consistency and see what style we prefer (beyond just pep8).
Let’s collect open questions for now:
- to indicate a variable that specifies an index/counter, e.g., the index of a trial, should we prefix with
i_trial) or with
- Created 4 years ago
- Comments:19 (11 by maintainers)
Top GitHub Comments
based on all of this how about:
- (Compute) Window -> we use compute_window at some public function calls to give a strong hint at the beginning, internally can use shorter “window”
- Crop, stays as crop to stay consistent with paper, mostly used in internal code
one word that pops to mind is also “segment” that point more directly to data / signals while annotations refers to the target variable.