Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Installation issues on x86_64 Ubuntu 20.04.4

See original GitHub issue

I’m trying to use brainrender to visualize Neuropixel probe tracks, but ran into several issues during installation.

I began by trying a basic installation per the documentation:

conda create -n brainrender python=3.7
conda activate brainrender
pip install brainrender
>> from brainrender import Scene; s = Scene()

This leads to issue #197, which is fixed by pinning vedo==2021.0.5. However, this leads to a new issue, which is an unrecognized keyword argument print_authors passed to the Atlas constructor on line 26 of The latest source shows that this should be handled by commit ae92a40c2769f249d8ae7a040a64d43fad949ba0, so I tried installing from source using pip install git+ This leads to a situation where I can import brainrender, but from brainrender import Scene fails because Python can’t find the brainrender module. Even though the wheel reports building successfully and pip show brainrender shows the correct path. This issue persists also using pip install and pip install It also occurs if I clone from source and install using pip install .

FYI, the documentation linked to above references a different, deprecated repository: I wonder if it is also not necessary to use python 3.7 as the documentation suggests, since 3.8 is listed as valid target in both and pyproject.toml.

Also, It looks like the default PyPI release is version, although for some reason this is timestamped January 19, 2022, while version actually has a later release date.

Anyways, I eventually discovered with pip show -f and pip install -vvv that dist-info and tests are added to the wheel, but the actual brainrender package is not! I suspect the issue lies in line 90 of packages=find_packages(include=("tests",)),, which should probably include brainrender.

In the end, if I clone from source and do an editable install with pip install -e ., this works and I can finally create a Scene object. Actually, I’m having new issues with some of the provided examples clearly not rendering properly, but that may be a separate issue, and I haven’t had time to look into it yet.

Issue Analytics

  • State:closed
  • Created a year ago
  • Comments:7

github_iconTop GitHub Comments

grahamfindlaycommented, May 1, 2022

Thanks @noisysky . I actually got the most recent version working using an editable pip install from source (pip install -e) before opening the issue 😄. Just wanted to make sure someone was aware of the problem.

FedeClaudicommented, May 6, 2022

I’ve been trying to figure out what is going on here.

With the version that is currently on github I can install and use brainrender on windows. I can install it on Mac, and it all looks fine but when I try to use it it fails to find loguru or any other package used. So it finds brainrender, it’s not the same as what you had @grahamfindlay but it doesn’t find other package used within brainrender even though they were install correctly and are in the environment.

I have no idea why this is happening now or how to fix it! pip install -e . also doesn’t seem to work for me

Read more comments on GitHub >

github_iconTop Results From Across the Web

Swift Installation Problem on Ubuntu 64-bit 20.04.4
Hello, I followed the instructions to install swift 5.6.1. on Ubuntu 20.04.4. However, when I launch swift, I get these error messages below ......
Read more >
apt - Installation problem in Ubuntu 20.04
1 Answer 1 · Purge the problematic packages: sudo dpkg -P amdgpu && sudo dpkg -P amdgpu-dkms. More likely this will work! ·...
Read more >
Installation/SystemRequirements - Community Help Wiki
This page details the hardware required to run Ubuntu and its derivative versions. Most people will want to install a desktop system such...
Read more >
[Solved] Ubuntu 20.04.2 LTS installation error with CUDA ...
wget sudo mv ...
Read more >
Ubuntu 22/Vivado 2022.1 Obscure Library Install Issues - Reddit
It does work on 20.04.4. Here is the list of libraries I installed,. sudo apt install libncurses5. sudo apt install libtinfo5.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found