Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unable to resolve dependencies

See original GitHub issue

When using


I’m unable to resolve any ai types.

If I switch to


instead, I get failures to resolve kotlin-bom

Unresolved dependency: 'org.jetbrains.kotlin:kotlin-bom:jar:1.6.10'

Currently it seems impossible to use this project with the current pom setup. Do you have an example of an external project using kotlingrad where this works?

Issue Analytics

  • State:open
  • Created a year ago
  • Comments:8 (2 by maintainers)

github_iconTop GitHub Comments

snowe2010commented, May 10, 2022

Ok, seeing something really weird. I wipe your artifact from my .m2 repo and then the gradle build works fine.

❯ rm -rf ~/.m2/repository/ai/

kotlingrad-consumer on  master [?] via ☕ v15.0.2 via 🅺 v1.6.21 on ☁️  (us-west-2)
❯ ./gradlew run

> Task :run
z(x, y)         = ((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)
z(0, 1)         = 0.0
∂z/∂x           = d(((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) / d(x)
                = 4.0
∂z/∂y           = d(((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) / d(y)
                = 0.0
∂²z/∂x²         = d(((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) / d(y)
                = -8.0
∂²z/∂x∂y        = d(d(((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) / d(x)) / d(y)
                = -8.0
∇z              = {x=d(((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) / d(x), y=d(((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) / d(y)}
                = [4.0, 0.0]ᵀ
t(x, y)         = (((d(d(((((1.0) sum ((x) prod (2.0))) sum (-3.0)) sum (y)) sum ((((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) prod ((y).pow(-1.0)))) / d(y)) / d(x)) sum (((((x) prod ((sub(sin((x) prod (y)))) sum (y))) prod (4.0)) prod ((y).pow(-1.0))) prod (3.0))) sum (-2.0)) sum (sin(x))

2 actionable tasks: 1 executed, 1 up-to-date

As soon as I try to build using maven it fails. I believe this might be related to our nexus repository. I’ll get back to you in a bit.

snowe2010commented, May 13, 2022

Yes, Gradle can be quite difficult to use, though I do like it more than Maven for most use cases. Looking at your build.gradle though, it is quite complex, so I would expect some issues with that. I don’t completely understand everything you’re doing, especially with the git submodules and this shipshape library. I think most of the issues here are coming from your use of kotlin multiplatform. Have you tried following along with how a project like kotest does multiplatform?

Read more comments on GitHub >

github_iconTop Results From Across the Web

Unable to resolve dependency for ':app@debug ...
23 Answers 23 · Ensure that your Android Studio does not need to go through any proxy. · Export the certificate where you...
Read more >
Unable to resolve dependencies of NuGet packages
Clear the NuGet cache files. You do this in the following way: In the toolbar of Visual Studio, navigate to Tools » NuGet...
Read more >
Android Studio “Unable to resolve dependency” Error
The most of users encounter errors like “Unable to resolve dependency for ':app@debug/ compileClasspath': Could not find any
Read more >
Unable to resolve dependency tree error in Angular while ...
To fix Unable to resolve dependency tree error in Angular while installing `npm` packages follow the below steps. 1.
Read more >
(Solved) ERESOLVE unable to resolve dependency tree ...
Solution · 1. Remove node_modules and package-lock.json and then run · 2. Or try clearing out npm cache · 3. Or run command...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found