Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Does not work with Cassandra 3.0

See original GitHub issue

Because Cassandra 3.0 changed some internal tables and older versions of drivers try to access them, both tools crash when trying to connect. Please update the Java driver.

# ./cassandra-unloader -f xxx.csv -host -schema
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See for further details.
Exception in thread "main" com.datastax.driver.core.exceptions.NoHostAvailableException: All host(s) tried for query failed (tried: / (com.datastax.driver.core.exceptions.InvalidQueryException: unconfigured table schema_keyspaces))
        at com.datastax.driver.core.ControlConnection.reconnectInternal(
        at com.datastax.driver.core.ControlConnection.connect(
        at com.datastax.driver.core.Cluster$Manager.init(
        at com.datastax.driver.core.Cluster.init(
        at com.datastax.driver.core.Cluster.connect(
        at com.datastax.loader.CqlDelimUnload.setup(
        at com.datastax.loader.CqlDelimUnload.main(

Issue Analytics

  • State:closed
  • Created 8 years ago
  • Comments:8 (1 by maintainers)

github_iconTop GitHub Comments

xqchen1commented, Mar 31, 2016

I loaded 62 million rows of data to a table with 150 columns. The load rate was about 8200 rows per second on a 4 node cluster with 16 cores (32 logical)/SSDs/264GB memory. In a small cluster of 4 VM nodes , my load rate was about 1000 rows per second with 1 thread. You want to create smaller CSV files so you can run your job in parallel. If compaction is falling behind, you may want to lower number of threads. You need to monitor where is the bottleneck. It’s a tuning process.

brianmhesscommented, May 10, 2016

I didn’t close this issue, but yes we support 3.0 now.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Cassandra 3.0 is not accepting Java 11 installation
Cassandra 3.x doesn't support Java 11. Only Cassandra 4.0 will support Java 11 - see docs. You need to install Java 8 to...
Read more >
DataStax Spark Connector for Apache Cassandra - Issues
Key Summary Assignee Re... SPARKC‑693 Support for Apache Spark 3.3* Jaroslaw Grabowski Jac... SPARKC‑692 Direct Join ‑ Match Error on aliased columns Jaroslaw Grabowski Ja... SPARKC‑691...
Read more >
Cassandra connection does not work after updating connector ...
Im trying to update spark-cassandra-connector from 1.5.0-M2 to 1.6.0. ****************. val phantom = "com.websudos" %% "phantom-dsl" % "1.25.4"
Read more >
Spark Cassandra connector 3.0.1 unable to access ...
I'm unable to access any materialized view that used to work on v2.4.2 of the connector. Here are the steps to reproduce the...
Read more >
Spring Data for Apache Cassandra - Reference Documentation
However, if you encounter issues or you need advice, feel free to use one of the links below: Community Forum. Spring Data on...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found