Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Yanking fails on some pages?

See original GitHub issue

The page in question: (it’s a Russian torrent tracker, and sorry, it looks like hell, but unfortunately, I still use it…)

Any mapping related to yanking simply fails. For instance, if I press yy, Surfingkeys capture the first y, show a menu with the suggestions, but then I press the second y and nothing happens.

Other mappings (and re-mappings) seem to work, I tried both with the default config and also with my own config. Yanking on other pages works, too. Can reproduce both in Firefox and Brave. Tried both with uBlock origin on and off.

They probably have something on that page that breaks / blocks certain parts of Surfingkeys code? Any ideas may be how to fix it? Would be soo grateful 😃

Surfingkeys v.1.1.1.

Firefox v.106.0.4.

Issue Analytics

  • State:closed
  • Created a year ago
  • Reactions:2
  • Comments:7 (2 by maintainers)

github_iconTop GitHub Comments

yaohappinesscommented, Nov 6, 2022

With this policy of constant updates we can’t downgrade while this being fixed? With Firefox, as I recall, you can disable updates for the installed extensions, but as for Chrome, there’s nothing we can do, I think?

Get an history version of the extension, e.g. this site Unzip the crx extension file, and open the Developer mode on chrome://extensions/, and then click “Load unpacked” button to manually load the unzipped extension.

On Windows, I revoked the write permissions of Surfingkeys plugin directory which also works.

yaohappinesscommented, Nov 6, 2022

I had a similar problem. It seems a problem about “Permissions in Cross-Origin Iframes”. It happens when the current frame and the main frame are cross site origins.

v1.0.9 don’t have this problem. It should be caused by the commit 936edff.

Error message:

DOMException: The Clipboard API has been blocked because of a permissions policy applied to the current document. See for more details.

This link shows an example. It contains a cross origin frame. And the ad at the bottom of the page is also a cross origin frame. See picture below.

Screenshots 2022-11-06 193744

Read more comments on GitHub >

github_iconTop Results From Across the Web

How to fix a project page after yanking a gem?
My gem's main page on RubyGems: is using a description about the gem being yanked instead of the gemspec's description.
Read more >
PEP 592: Support for "Yanked" Files in the Simple Repository ...
This PEP proposes adding the ability to mark a particular file download on a simple repository as “yanked”. Yanking a file allows authors...
Read more >
tmux-plugins/tmux-yank - GitHub
GitHub - tmux-plugins/tmux-yank: Tmux plugin for copying to system clipboard. ... Note: Some versions of macOS (aka OS X) have been reported to...
Read more >
How to cope with hardware-poisoned page-cache pages
hole-punching, can be allowed to work normally since the end result will be correct. But if the page is accessed in other ways,...
Read more >
Error description. ROHA Yanking may fail with errors during RG failover Issuing halt -q command to trigger HA failover from active to standby...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found