Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

resolve 1.7.0 fails to find bootstrap's package.json

See original GitHub issue

We’re using bootstrap-loader (pinned at version 2.0.0-beta.22) in our webpack configuration to load bootstrap (pinned at version 4.0.0-alpha.6). bootstrap-loader depends on resolve. We were not pinning resolve’s version. Our build worked with resolve 1.6.0 but fails with 1.7.0 with this curious error message:

ERROR in ./~/bootstrap-loader/lib/bootstrap.loader.js!./~/bootstrap-loader/no-op.js
Module build failed: Error: Cannot find module '/builds/.../node_modules/bootstrap/package.json/package.json'
    at Function.Module._resolveFilename (module.js:325:15)
    at Function.Module._load (module.js:276:25)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at exports.default (/builds/.../node_modules/bootstrap-loader/lib/utils/checkBootstrapVersion.js:8:20)
    at Object.module.exports.pitch (/builds/.../node_modules/bootstrap-loader/lib/bootstrap.loader.js:159:65)
 @ ./~/bootstrap-loader/loader.js 2:17-61
 @ multi ./app/App.jsx bootstrap-loader

Note that it’s looking for node_modules/bootstrap/package.json/package.json instead of node_modules/bootstrap/package.json, which is an existing file.

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:30 (15 by maintainers)

github_iconTop GitHub Comments

mgedmincommented, Apr 16, 2018

Thank you very much! 1.7.1 works great!

krainboltgreenecommented, Apr 10, 2018

I know this can be difficult, but that change really should have warranted a major version bump.

Read more comments on GitHub >

github_iconTop Results From Across the Web

"Unable to resolve dependency tree" error during NPM install ...
The first thing to check is to ensure you are using the "LTS" version of node, NOT the "current" version of node. Then...
Read more >
Could not resolve dependency when running npm i
I have no idea about what is happening. This command has always worked like a charm. Here's my package.json: "dependencies": { "@angular/ ...
Read more >
Bug listing with status RESOLVED with resolution OBSOLETE ...
systemPrefs with at least two files" status:RESOLVED resolution:OBSOLETE ... Bug:325849 - "dev-lang/spidermonkey-1.7.0 fails to compile with hardened GCC ...
Read more >
bootstrap-icons - npm
Official open source SVG icon library for Bootstrap. ... Start using bootstrap-icons in your project by running `npm i bootstrap-icons`.
Read more >
unable to resolve dependency tree angular -
You have dependency conflict (incorrect and potentially broken dependency) as it says, so try to run the command with --force , or --legacy-peer-deps...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found