Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Can't install extension on ArchLinux

See original GitHub issue

General information

  • Operating system + version: ArchLinux 5.1.5

  • Browser + version: Chromium 74.0.3729.169 Arch Linux

  • Information about the host app:

    • How did you install it? by pacman
    • If installed an official release, put a version ($ browserpass --version): Browserpass host app version:
  • Information about the browser extension:

    • How did you install it? by pacman
    • Browserpass extension version as reported by your browser: I can’t see it in my browser.

If you are getting an error immediately after opening popup, have you followed the Configure browsers documentation section?

No, but it is said that

If you installed a distro package above, you are done!

So I did nothing.

Exact steps to reproduce the problem

  1. I used to have browserpass native from pacman and Chromium extension from webstore.

  2. I found it can’t work one day and I tried to delete the webstore version and install from pacman. But the extension does not come out as expected.

What should happen?

It seems that all the things installing from pacman can be used out of the box. So the extension should be found in my browser.

What happened instead?

Apparently, it does not appear.

Did I do something wrong?

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:5 (3 by maintainers)

github_iconTop GitHub Comments

maximbazcommented, May 29, 2019

try to drag-and-drop the crx file from /usr/lib/browserpass-chromium/ into chrome://extensions, will it help?

is it the first time you install browserpass, or you played with it before and uninstalled it at some point?

also try to run chromium with a new profile to make sure the problem is not with your own profile:

chromium --user-data-dir /tmp/test1

maximbazcommented, May 29, 2019

No I don’t think so - make sure to ping me if that happens!

My best guess on what happened is that for some reason your Chromium profile blocked our extension, and by manually drag-n-dropp’ing it into chrome://extensions you told Chromium that you want to unblock it. Now it should keep working and auto-updating as expected.

Closing for now, enjoy your new extension 😉

Read more comments on GitHub >

github_iconTop Results From Across the Web

[SOLVED] Gnome Shell Extensions won't install from website
I was able to install gnome-shell-extension-mediaplayer-git from the AUR. (Which also pulls in gnome-shell-extension-common-git.) It works fine.
Read more >
Gnome Extension app is not opening.. : r/archlinux - Reddit
I tried extension manager app from Flathub.. it didn't work either.. extension settings isn't opening of any extensions.. they are updating ...
Read more >
Gnome-Extensions didn't install - Unix & Linux Stack Exchange
I am using arch linux and on that i installed gnome and chrome-gnome-shell (I use chrome as defualt browser) and then head up...
Read more >
How to install Gnome Shell extensions the easy way with ...
The Extension Manager tool is available for users to install through the Arch Linux User Repository. To start the installation process, use the ......
Read more >
How To Install & Use Gnome Extensions in Fedora ... - YouTube
Your browser can't play this video. ... How To Install & Use Gnome Extensions in Fedora, Arch & Ubuntu Linux Distributions - Browser...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found