Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Can't save settings

See original GitHub issue

General information

  • Operating system + version: macOS Monterey 12.4
  • Browser + version: Google Chrome 102.0.5005.61
  • Information about the host app:
    • How did you install it? Installed with Homebrew
    • If installed an official release, put a version ($ browserpass --version): v3.0.8
  • Information about the browser extension:
    • How did you install it? Via the Chrome Web Store
    • Browserpass extension version as reported by your browser: 3.7.2

If you are getting an error immediately after opening popup, have you followed the [Configure browsers] - N/A

Exact steps to reproduce the problem

  1. Right-click icon in browser menu

  2. Choose options

  3. The dialog displays, but there’s no option to save preferences:


(I’ve ticked these boxes. How do I now get it to save those options? Clicking the X to close the dialog loses the changes).

What should happen?

I should be able to save settings.

What happened instead?

I need to change settings to a) enable OTP, and b) give a custom path to the GPG binary (I’m on an M1 Mac, so need to give it: /opt/homebrew/bin/gpg).

Per the screenshot, there’s no option to save. I’ve been using the plugin for ages on lots of browsers and I can’t for the life of me remember whether there ever was a save button in the preferences.

I’ve discovered from the readme that I can put a .browerpass.json in the root of my .password-store folder, and in doing so, I’m able to get the plugin to pick up the correct path to the binary, but it doesn’t seem to pick up the enableOTP field. My .browserpass.json file looks like this:

  "enableOTP": true,
  "gpgPath": "/opt/homebrew/bin/gpg"

As I say, the gpgPath is now being picked up correctly, but it still doesn’t parse the OTP field in my password files. I’ve looked at the code, and as far as I can tell enableOTP is the correct name for the setting, but it’s not working.

It’s always worked until now - what am I doing wrong?

Your advice very much appreciated from an ever-grateful user. 😃

Issue Analytics

  • State:open
  • Created a year ago
  • Comments:7 (1 by maintainers)

github_iconTop GitHub Comments

maximbazcommented, Jun 1, 2022

Ack, and thanks for the investigation!

eraydcommented, Jun 1, 2022

This looks like a bug in Chrome v102, and not a Browserpass bug. I’ve just tested it on Monterey 12.4, and can confirm that it works perfectly on Chrome v101, but v102 fails to fully render the options dialog. The failure point appears to be inconsistent.

This screenshot is v101: Screen Shot 2022-06-02 at 09 11 36

These two are both v102: Screen Shot 2022-06-02 at 09 13 45 Screen Shot 2022-06-02 at 09 14 41

It appears there are two separate problems here. In the first screenshot, the options body HTML does not appear to be injected by Chrome at all. I cannot currently think of a way to work around this. Repeatedly reloading the options screen does eventually seem to result in the second screenshot.

In the second screenshot, the full markup of the options box is injected, but is displayed inside an iframe container (which itself is inside a shadow root) that inherits the wrong height from its ancestor container. This can be worked around on a temporary basis by using the developer tools element inspector. Right-clicking the options popup title bar, then selecting ‘inspect’, will take you to approximately the location in the screenshot below. You may need to expand some stuff in order to locate the precise element that needs to be tweaked. Screen Shot 2022-06-02 at 09 26 02

@maximbaz Hopefully Google fixes this one quickly, but if not, we may need to consider moving our options into a separate tab, rather than using the default options mechanism as we do currently.

Read more comments on GitHub >

github_iconTop Results From Across the Web

windows 10 can't save any type of settings
1. Type "Control Panel" without the quotes on the search box next to Start Menu and click on it. 2. Then click on...
Read more >
Unable to save settings : IntelliJ IDEA - java - Stack Overflow
Solution is to go back to your windows OS and restart it and switch to linux. Also, you could hold shift and press...
Read more >
Cannot save settings in controler - Ubiquiti Community
I cannot get the controller software to save my guest network settings. I currently have the guest portal enabled, and if I uncheck...
Read more >
Can't Save Settings -
I've installed this plug in and am trying to change some of the default settings under the Opportunity Defaults and Email tabs. In...
Read more >
Game won't save my settings and resets them :: Dead Rising 3 ...
Try turning off the Steam Cloud. From within the Library in the steam client, right-click the game in the list & choose "Properties"....
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found