Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

2.1.0 can't start in standalone mode

See original GitHub issue

Describe the bug

With the 2.1.0 zip file, browserup-proxy can’t start with the following error:

$ java -version
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

$ uname -a
Darwin MacBook-Pro-2.local 19.4.0 Darwin Kernel Version 19.4.0: Wed Mar  4 22:28:40 PST 2020; root:xnu-6153.101.6~15/RELEASE_X86_64 x86_64

$ cd browserup-proxy-2.1.0/bin

$ ./browserup-proxy
Running BrowserUp Proxy, powered by LittleProxy.
[INFO  2020-05-21T16:06:25,046 com.browserup.bup.proxy.Main] (main) Starting BrowserUp Proxy version ${project.version}
[INFO  2020-05-21T16:06:25,137 org.eclipse.jetty.util.log] (main) Logging initialized @6091ms to org.eclipse.jetty.util.log.Slf4jLog
[INFO  2020-05-21T16:06:25,290 org.eclipse.jetty.server.Server] (main) jetty-9.4.26.v20200117; built: 2020-01-17T12:35:33.676Z; git: 7b38981d25d14afb4a12ff1f2596756144edf695; jvm 1.8.0_77-b03
[INFO  2020-05-21T16:06:25,317 org.eclipse.jetty.server.session] (main) DefaultSessionIdManager workerName=node0
[INFO  2020-05-21T16:06:25,317 org.eclipse.jetty.server.session] (main) No SessionScavenger set, using defaults
[INFO  2020-05-21T16:06:25,320 org.eclipse.jetty.server.session] (main) node0 Scavenging every 660000ms
May 21, 2020 4:06:25 PM org.glassfish.jersey.internal.inject.Providers checkProviderRuntime
WARNING: A provider io.swagger.v3.jaxrs2.integration.resources.OpenApiResource registered in SERVER runtime does not implement any provider interfaces applicable in the SERVER runtime. Due to constraint c
onfiguration problems the provider io.swagger.v3.jaxrs2.integration.resources.OpenApiResource will be ignored.
[INFO  2020-05-21T16:06:26,075 org.hibernate.validator.internal.util.Version] (main) HV000001: Hibernate Validator 6.0.17.Final
May 21, 2020 4:06:26 PM org.glassfish.jersey.internal.Errors logErrors
WARNING: The following warnings have been detected: WARNING: Unknown HK2 failure detected:
MultiException stack 1 of 1
java.lang.NoSuchMethodError: javax.validation.BootstrapConfiguration.getClockProviderClassName()Ljava/lang/String;

(refer to the attached bup.log for the detail)

To Reproduce Steps to reproduce the behavior:

  1. Download the zip
  2. Extract it
  3. Start by running ./browserup-proxy in the bin directory
  4. See error

Expected behavior

It should start without errors.

Screenshots If applicable, add screenshots to help explain your problem.

Please complete the following information:

  • OS: macOS Catalina with Java 1.8.0_77
  • Browser -
  • Version -

Additional context

I also tried with the following environments (all are with official images on Docker Hub) but on all of them, browserup-proxy doesn’t start with the same error:

  • Openjdk 11 (openjdk:11)
    # java -version
    openjdk version "11.0.7" 2020-04-14
    OpenJDK Runtime Environment 18.9 (build 11.0.7+10)
    OpenJDK 64-Bit Server VM 18.9 (build 11.0.7+10, mixed mode)
  • Openjdk 15 (openjdk:15)
    # java -version
    openjdk version "15-ea" 2020-09-15
    OpenJDK Runtime Environment (build 15-ea+23-1098)
    OpenJDK 64-Bit Server VM (build 15-ea+23-1098, mixed mode, sharing)

I also tried to create an archive from the code with the tag v2.1.0 by running gradlew build --info but using the archive, browserup-proxy doesn’t start with the same error as well.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Reactions:1
  • Comments:5 (2 by maintainers)

github_iconTop GitHub Comments

dpowellcommented, May 26, 2020

This should be fixed now for Java 8 - 13, please let us know if you continue to have issues.

thiagotrentincommented, May 25, 2020

Same issue here, although running on windows environment Previous version still working fine

Read more comments on GitHub >

github_iconTop Results From Across the Web

Spark Standalone Mode - Spark 2.1.0 Documentation
You can launch a standalone cluster either manually, by starting a master and workers by hand, or use our provided launch scripts. It...
Read more >
structured streaming 2.1.0 kafka driver works on YARN with
However when we try to launch on spark standalone with deploy mode=cluster, we get the ClassNotFoundException: Failed to find data source: ...
Read more >
Getting started — Jupyter Enterprise Gateway 2.1.0 ...
So container environments have two launches - one to launch the container itself, the other to launch the kernel (within the container). The...
Read more >
WildFly Admin Guide
WildFly can be booted in two different modes. A managed domain allows you to run and manage a multi-server topology. Alternatively, you can...
Read more >
Compose file version 2 reference - Docker Documentation
As with docker run , options specified in the Dockerfile, ... depends_on does not wait for db and redis to be “ready” before...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found