Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Create New Pin Error

See original GitHub issue

I tried to make a new PIN, but an error. this is my script

# -*- coding: utf-8 -*-
from py3pin.Pinterest import Pinterest

def test():
    username = ''
    password = ''
    email = ''

    # cred_root is the place the user sessions and cookies will be stored you should specify this to avoid permission issues
    cred_root = 'cred_root'
    pinterest = Pinterest(email=email, password=password, username=username, cred_root=cred_root)

    board_id = '854698904221395783'
    image_url = '25061712.jpg'
    description = 'description here'
    title = 'title test'
    link = ''

    return, image_url=image_url, description=description, title=title, link=link)

if __name__ == '__main__':

and this error occurred

Traceback (most recent call last):
  File "", line 22, in <module>
  File "", line 19, in test
    return, image_url=image_url, description=description, title=title, link=link)
  File "/home/crabs/Documents/gameplay/py3Pinter/py3pin/", line 325, in pin
    return, data=data).json()
  File "/home/crabs/Documents/gameplay/.py3PinEnv/lib/python3.6/site-packages/requests/", line 897, in json
    return complexjson.loads(self.text, **kwargs)
  File "/usr/lib/python3.6/json/", line 354, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.6/json/", line 339, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.6/json/", line 357, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

anyone can help?

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:7 (4 by maintainers)

github_iconTop GitHub Comments

MrCrapcommented, Nov 21, 2019

yes, that was my mistake. now it works well. You can continue now.


bstoilovcommented, Nov 20, 2019

That is already there, even before the change, probably you have some local change, or some branch is not merged.

or am I missing something, it seems to work on my side.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Windows Hello errors during PIN creation - Microsoft Learn
When you set up Windows Hello in Windows client, you may get an error during the Create a PIN step. This topic lists...
Read more >
How To Fix “Something Happened And Your Pin Isn't Available”
Reset PIN at Login Screen · Click on Set up My Pin below the error message. · Enter your Microsoft Account credentials. ·...
Read more >
Something happened and your PIN isn't available in Windows ...
Another method to solve the "PIN isn't available" error in Windows 10, is to uninstall the latest update. 1. In the login screen...
Read more >
7 Ways to Fix the Windows PIN Not Working in Windows 10
Open the Windows Settings app. · Go to Accounts. · Navigate to Your info in the left-sidebar. · Click on Sign in with...
Read more >
Something went wrong and your PIN isn't available? Here's ...
This can usually happen when your access control lists on the NGC folder are corrupted, in which case you will have to reset...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found