Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Argument List Too Long error - maybe cl eslint not respecting ignore

See original GitHub issue

Trying to follow along with the ESLint video from FEM, but running into a few issues, but here is one.

The following command line does not work.

./node_modules/.bin/eslint **/*.{js,jsx} --quiet

Neither does this:

./node_modules/.bin/eslint **/*.js --quiet

They both return ‘zsh: argument list too long: ./node_modules/.bin/eslint’

The following does:

./node_modules/.bin/eslint */*.jsx --quiet

So does this:

./node_modules/.bin/eslint **/*.jsx --quiet

I can only assume that this is because of the number of js files in the node_modules folder? But, eslint is supposed to ignore the node_modules folder by default. I try to run this using the --ignore-pattern flag, but doesn’t seem to matter.

I noticed a few glob sort of issues on the eslint repo and symlinks, but a bit over my head at the moment?

Is anybody else having this problem and is there a workaround?

For the time being, I am just going to use ./node_modules/.bin/eslint **/*.jsx --quiet and roll with it.

Issue Analytics

  • State:open
  • Created 6 years ago
  • Reactions:5
  • Comments:5

github_iconTop GitHub Comments

andrewnaevecommented, May 2, 2018

Hi friends

With zsh, the **/*.js needs to be in quotes.

my lint script looks like:

"lint": "./node_modules/.bin/eslint eslint '**/*.js' --fix"

hope that helps.

robkreiselcommented, Jan 18, 2018

And here is a great explanation of the ** globbing operator in zsh. And it appears to be the combination of **/* in zsh. For instance, ls **/* in bash works, but ls **/* in zsh will produce the same error of “argument list too long”.

Read more comments on GitHub >

github_iconTop Results From Across the Web

How can I edit my environment so that 'ls **/*.js' doesn't result ...
it returns 'argument list too long' when I run from the project root. The following works, but does not include all the files....
Read more >
kernel - "Argument list too long": How do I deal with it, without ...
I know why this happens: it is because there is a kernel limit on the amount of space for arguments to a command....
Read more >
eslint/eslint - Gitter
Quick question about version compatibility: I am using Node.js v 0.12.18 and upgrading it is not an option currently. The latest version of...
Read more >
please specify path to eslint package - -
方法一、重启项目. 方法二、先点 Disable ESlint ,再点 Automatic ESlint configuration ,问题解决了。. 5. 2. 1. IDEA specify path to ' eslint ' package 报错.
Read more >
Flycheck - Read the Docs
Prompt for a syntax checker to disable in the current buffer. For instance if you do not care for documentation conventions of Emacs...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found