Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unable to access via WebDav (Seafile)

See original GitHub issue

Hi ! 👋🏼

I experience some trouble to add a new vault with webDAV.

Some background: Running an instance of seafile with seafdav(webdav module) enabled and an nginx reverse proxy in front of it, I can access it from my browser without trouble and add a vault from this source.

NOW : I run a second instance, exactly the same, configuration of both nginx and seafile is the same, login via browser not a problem but this time unable to add a vault from this source!

Tried everything I could, debugged via CURL (and I could access the webdav without trouble on the “faulty” instance), I’m not able to make it work. Meeh.

Oh, yeah, I’m using Firefox and Firefox Nightly to test this, browser side.

The only error I get in the browser is this:

[error] WebDAV failed to connect: getValueForKey(...) is undefined; can't access its "filter" property setup-index.js:1:85071
[error] Failed establishing WebDAV connection: https://domain.tld/seafdav

If you think this does not have anything to do with the extension please feel free to tell me and to close the issue !

Have a great day and thanks for the awesome project !

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Reactions:1
  • Comments:10 (7 by maintainers)

github_iconTop GitHub Comments

perry-mitchellcommented, Oct 10, 2018

@imkwx Thanks for being super helpful and patient! It made this much easier. And now we have Seafile support, thanks to your issue. Cheers mate!

perry-mitchellcommented, Oct 10, 2018

@imkwx Just received a notification from Mozilla - 1.12.0 should be live. Please give it a moment to update 😃

Read more comments on GitHub >

github_iconTop Results From Across the Web

Unclear how to get WebDAV running
I'm trying to enable the WebDAV extension. I'm running seaf-server 8.0.8 on NixOS. A couple of things are unclear to me:.
Read more >
WebDAV extension - Seafile Admin Manual
Clients can't connect to seafdav server¶. By default, seafdav is disabled. Check whether you have enabled = true in seafdav.conf . If not,...
Read more >
Unable to use WebDAV secret
Hello,. I'm hosting Seafile server for years now and happiliy using it. Just one feature just won't work: Using WebDAV secret as password ......
Read more >
Seafdav can not login with seafile email and passwod ...
Use account email not login id, there could be webdav specific password if your server is configured to use it instead account password, ......
Read more >
WebDAV authentication with seafdav
Hello, been using Seafile for quite some time now. ... I wanted to enable WebDAV for a certain usecase but I can't manage...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found