Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

LAN mode not working

See original GitHub issue

What issue do you have? Please be as thorough and explicit as possible.

I’m trying to use pure LAN mode on my Sonoff devices in Home app and Hoobs. I have all my Sonoff devices (6x 4CHR3 and some BasicR3) on my separate IoT VLAN, and LAN control is turned on on all devices in the Ewelink app. This works fine as long as that VLAN has internet access, but not if I cut off internet access to that VLAN. I can still control all devices through the Ewelink app, which tells me that LAN control should be working, but they become unavailable in the iOS Home app, and shows up in the log as “reported as offline by WS”. In this state, I can’t control anything through neither Home app or Hoobs dashboard, only through the Ewelink app. I’ve tried restarting the plug-in and the RPI itself, but that doesn’t work. Only if I give the IoT VLAN internet access again, everything works again. I’ve noticed in the log, that if I do a restart with internet access, all my devices show up, but some of them will report as “LAN control unsupported/unavailable”, even though they have this turned on in the Ewelink app. Some devices seems to change their mind a minute or so later, and will report as “found locally via IP 192.168….” or “reported online by LAN” but I never get all my devices reported as LAN compatible. I’ve double checked in the app, and all devices have LAN control turned on. Anyway, if they are controllable through the Ewelink app, even without internet, they must be LAN controllable. Am I supposed to do something else to run in pure LAN mode? I realize that it needs the initial connection to retrieve my list of devices, but after that, if my internet connection drops, I can’t control anything through either Hoobs or the Home app, only through the Ewelink app.

Details of your setup.

  • Do you use (1) Homebridge UI-X (2) Homebridge CLI or (3) HOOBS? 3

  • Which version of Homebridge/HOOBS do you have? 4.0.104

  • Which platform do you run Homebridge/HOOBS on (e.g. Raspberry Pi/Windows/HOOBS Box)? Please also mention your version of Node.js/NPM if known. Raspberry Pi 4B, node is 14.18.0

  • Which version of this plugin (homebridge-ewelink) do you have? Has the issue started since upgrading from a previous version? 8.3.6. I haven’t tried to use pure LAN mode until now, so I can’t say if it has worked before.

  • Which eWeLink devices do you have that are causing issues? Please include product models if applicable. 6x 4CHR3, 3x BasicR3.

Please paste any relevant logs below.

Issue Analytics

  • State:closed
  • Created 2 years ago
  • Comments:27 (11 by maintainers)

github_iconTop GitHub Comments

bwp91commented, Oct 4, 2021

Or another option, whilst the plugin has access to the internet, you can remove your ewelink username and password from the config, (the plugin must already be in lan mode) and then restart, and it will use cache version of your devices and then you can connect the hoobs box to the sonoff vlan.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Minecraft LAN Not Working – How to Troubleshoot? - Alphr
1. Open the Control Panel on Windows. 2. In the search bar on the top right, type “Allow an App.” 3. Select “Allow...
Read more >
[100% Working] Fix Minecraft LAN Not Working 2022
LAN not Working means that your interconnections are empty. It means that Minecraft is not able to use the LAN connection properly. Minecraft...
Read more >
[FIXED] Not Able To Connect To Minecraft LAN Server
Sometimes, your Minecraft LAN is not working because the host computer is not powerful enough to handle being the server.
Read more >
Minecraft LAN games not working or showing up
Here's what to do if Minecraft LAN games not working or showing up. ... Open Command Prompt in administrator mode.
Read more >
10 Best Ways to FIx Minecraft LAN Not Working [2022]
When Windows Firewall restricts Minecraft, the Minecraft LAN not working problem can arise. Examine the Firewall configurations to guarantee ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found