Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

jupyter_client seems to have broken

See original GitHub issue

Not sure if anyone else is seeing this; I’m on Arch Linux. Trying different install options to see if the issue persists.

Traceback (most recent call last):
  File "/usr/bin/cq-editor", line 11, in <module>
    load_entry_point('CQ-editor==0.1.0.dev0', 'gui_scripts', 'cq-editor')()
  File "/usr/lib/python3.8/site-packages/cq_editor/", line 16, in main
    win = MainWindow()
  File "/usr/lib/python3.8/site-packages/cq_editor/", line 42, in __init__
  File "/usr/lib/python3.8/site-packages/cq_editor/", line 98, in prepare_panes
  File "/usr/lib/python3.8/site-packages/cq_editor/widgets/", line 24, in __init__
    self.kernel_client = kernel_client = self._kernel_manager.client()
  File "/usr/lib/python3.8/site-packages/qtconsole/", line 63, in kernel_client
    if kernel_client.channels_running:
  File "/usr/lib/python3.8/site-packages/jupyter_client/", line 141, in channels_running
  File "/usr/lib/python3.8/site-packages/jupyter_client/", line 199, in control_channel
    self._control_channel = self.control_channel_class(
TypeError: ChannelABC() takes no arguments

[1]  + 56397 exit 1     cq-editor

Issue Analytics

  • State:closed
  • Created 4 years ago
  • Comments:14 (7 by maintainers)

github_iconTop GitHub Comments

cjgkcommented, Mar 15, 2020

@jmwright Worked! And it was in the readme too, embarrassing… Thank you!

r4dr3fr4dcommented, Mar 18, 2020

downgrading seems to be the appropriate solution. Will close since conda is the supported installation method.

Read more comments on GitHub >

github_iconTop Results From Across the Web

5.3.3 seems to be broken · Issue #480 · jupyter/jupyter_client
5.3.2 and 5.3.3 are broken. I've run pip install jupyter-client==5.3.1 to fix it. Reproduce the problem: Have a clean install of Anaconda ...
Read more >
Updating Anaconda has broken Jupyter - Google Groups
If I run "conda update ipython" conda says I have 6.2.1, but if I run "pip freeze" then I get 3.2.3. So something...
Read more >
Jupyter Notebook 500 : Internal Server Error - Stack Overflow
Try upgrading jupyter hub first: pip install --upgrade jupyterhub pip install --upgrade --user nbconvert. If you are inside a conda ...
Read more >
Recovering from a Jupyter Disaster | by Marius van Niekerk
These notebooks are copies at a point in time of a notebook, when it was last saved. By default only one snapshot exists...
Read more >
Jupyter run configuration no longer works after upgrade to ...
I have upgraded my PyCharm 2018.3 to 2019.1 (professional), which has broken all Jupyter support. My projects have a run configuration...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found