Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Problem installing CQ-editor

See original GitHub issue


I cannot install CQ editor in conda, with conda prompt, with admin permissions.

I am a begginer and I am turning around this several days, so I ho anyone could save me.

I followed that instructions. First repository didn’t work no matter how long I wait:

(base) C:\Windows\system32>conda install -c cadquery -c conda-forge cq-editor=master Collecting package metadata (current_repodata.json): done Solving environment: failed with initial frozen solve. Retrying with flexible solve. Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source. Collecting package metadata (repodata.json): done Solving environment: /

Second repository also failed:

`(base) C:\Windows\system32>conda env create -f cqgui_env.yml -n cqgui

SpecNotFound: Invalid name, try the format: user/package

(base) C:\Windows\system32>conda activate cqgui Could not find conda environment: cqgui You can list all discoverable environments with conda info --envs.

(base) C:\Windows\system32>python python: can’t open file ‘’: [Errno 2] No such file or directory

(base) C:\Windows\system32>`

Anyone knows what I could try? i try this in 2 different windows 10 installations already. Jupyter notebooks works fine.


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:6 (3 by maintainers)

github_iconTop GitHub Comments

adam-urbanczykcommented, Sep 11, 2020

Looks like it worked. Or am I missing something?

z009LLcommented, Sep 11, 2020

jmwright and adam-urbanczyk thanks!

Adam, yes were missing something because still cq editor does not launch. Anyways, I uninstall anaconda (after try 1000 things) and paste your lines again, and this time cq editor launch and seems to worked perfectly.

Now I can import any python library to cq editor, right?

THANKS! so many hours

Read more comments on GitHub >

github_iconTop Results From Across the Web

4 Common CKEditor Installation Mistakes And How To Avoid ...
Mistake #1: Installing CKEditor Full Package and not using all of its features. Decide which CKEditor functionalities are indispensable to ...
Read more >
Problem With Installing | Forums
Hello,I am using WP2.51 and I uploaded the editor to my plugins folder but when I go to activate it, WP isn't showing...
Read more >
problems with installation | Forums
Hello, i'have installed FCKeditor 2.4.3 on Plone 2.5.3, the installation HAS HAD POSITIVE , BUT WHEN I TRY TO ACTIVATE the EDITOR, ...
Read more >
Unable to install CKEditor - Forums
I'm having difficulty installing either CKEditor or FCKEditor (either will do) on my Joomla 1.5.14 I've tried using the Joomla Extension ...
Read more >
Problem Installing CKEditor - Forums
I downloaded CKEditor on my Mac. The file was not zipped when it downloaded . I have a php mySQL running on my...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found