Rename Automaton.attributes()
See original GitHub issue@eliotwrobson So you probably recall that I recently added an Automaton.attributes()
method to retrieve all the public (non-underscore-prefixed) attributes on an Automaton instance, inspired by @Tagl’s recent PR. However, I find the current name a little ambiguous, since some members that are technically considered attributes are excluded from the resulting dict
.
Here are some alternative ideas I have, mostly based on the observation that every public Automaton attribute also appears to be an input parameter to its respective __init__
:
parameters
input_parameters
input_params
I’m also considering if this would be better as a @property
rather than a method. I like the brevity of omitting any verbiage, but on the flip side, want to property communicate that this method isn’t an input parameter in itself.
Thoughts?
Issue Analytics
- State:
- Created a year ago
- Comments:5 (5 by maintainers)
Top GitHub Comments
@eliotwrobson Closing this now because the related PR has been merged. Thanks for your feedback on this.
@eliotwrobson That’s a thought, but I think I’d rather just use
input_parameters
with an updated comprehension: