Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Standard installation method is not working

See original GitHub issue

Problem description

I have a working distribution of Calliope on my machine, and it works great. However, I’m helping a colleague install it on his machine, and the install is not working. It seems the default is to import Calliope 0.6.2, and there are errors with the enum package. I’ve included the full traceback below.

Steps to reproduce the problem

I use the standard installation from a command line:

conda create -c conda-forge -n calliope_alt calliope

which creates a new environment called calliope_alt with the package in it (I call it calliope_alt since my working distribution is an environment named calliope). However, when I open a python3 interpreter and try to import calliope, I get a set of errors:

(calliope_alt) $ python3
Python 3.6.10 | packaged by conda-forge | (default, Apr 24 2020, 16:27:41) 
[GCC Clang 9.0.1 ] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import calliope
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/calliope/", line 2, in <module>
    from calliope.core import AttrDict, Model, read_netcdf, _logger, set_log_level
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/calliope/core/", line 1, in <module>
    from calliope.core.model import Model, read_netcdf
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/calliope/core/", line 28, in <module>
    from import run as run_backend
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/calliope/backend/", line 14, in <module>
    import calliope.backend.pyomo.model as run_pyomo
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/calliope/backend/pyomo/", line 16, in <module>
    import pyomo.core as po  # pylint: disable=import-error
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyomo/core/", line 14, in <module>
    from pyomo.core.base import *
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyomo/core/base/", line 11, in <module>
    import pyomo.core.kernel
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyomo/core/kernel/", line 15, in <module>
    import pyomo.opt
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyomo/opt/", line 14, in <module>
    from pyomo.opt.base import *
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyomo/opt/base/", line 14, in <module>
    from pyomo.opt.base.convert import *
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyomo/opt/base/", line 16, in <module>
    from pyomo.opt.base.formats import guess_format
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyomo/opt/base/", line 16, in <module>
    from pyutilib.enum import Enum
  File "/Users/aph416/opt/anaconda3/envs/calliope_alt/lib/python3.6/site-packages/pyutilib/enum/", line 18, in <module>
    package) that supersedes this library.""")
ImportError: pyutilib.enum has been removed.

Python 3 now has an enum implementation in the standard library (also
available for older Python versions as the third-party enum34 PyPI
package) that supersedes this library.

This seems to be related to this error, but I could not figure out a quick fix. On closer inspection, I see that my Calliope version is 0.6.2. I’ve tried forcing conda to install a specific version using calliope=0.6.5 or calliope=0.6.4, but this doesn’t solve the problem.

Calliope version

I’m trying to install 0.6.5 (I was originally trying for 0.6.4, but this seems to pop up for any version). However, conda seems to be installing 0.6.2.

Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:10 (9 by maintainers)

github_iconTop GitHub Comments

brynpickeringcommented, Jun 26, 2020

Just remove coincbc (referring to the CBC solver) from the list @bbrannon4, since it isn’t available via conda forge for Windows

ahilberscommented, Jun 24, 2020

In case anyone runs into this issue, running the install with the following command seems to work (credit to @jfallon1997, similar idea to @timtroendle 's above):

conda create -n calliope -c conda-forge calliope=0.6.5 python=3.8.1 numpy=1.16.5 pandas=0.25.3 pyomo=5.6.8 pyutilib=5.7.3 coincbc
Read more comments on GitHub >

github_iconTop Results From Across the Web

How to troubleshoot Windows Installer errors - Microsoft Support
Identify Windows Installer issues · Click Start, click Run, type cmd, and then click Command Prompt. · At the command prompt, type the...
Read more >
[SOLVED] Windows 10 Could Not Complete the Installation + ...
The second method of solving error “Windows could not complete the installation Windows 10 Shift 10 not working” is to enable administrator ......
Read more >
Standard Installation Procedure
Standard Installation Procedure. 1. Start Windows. 2. Insert the CD-ROM or download the setup file from the Solutions Cafe. Run the installation by ......
Read more >
Standard installation of the application
Force download of the installation package. Selecting the method of application installation: · Do not install application if it is already installed. ·...
Read more >
Troubleshooting Your Initial Installation - PTC Support
When an installation fails, the installer logs are not written to the standard output directory of <installation directory>/installer/logs. Action: In this case ...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found