Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Build with Facbeook iOS SDK v12 fails with 'FBSDKCoreKit/FBSDKSettings.h' file not found

See original GitHub issue

Bug Report

Before opening

  • Did you try the latest release?
  • Did you look for existing issues?

Ad Modules




  • Android:
  • iOS: 15
  • react-native-fbads: 7.0.5
  • react-native:0.65.1

Current Behaviour

Until this morning our release builds ran smoothly but re-running the same build that worked this morning fails with the following error:

/Users/user/actions-runner/_work/user-mobile/user-mobile/node_modules/react-native-fbads/ios/ReactNativeAdsFacebook/EXAdSettingsManager.m:10:9: 'FBSDKCoreKit/FBSDKSettings.h' file not found

#import <FBSDKCoreKit/FBSDKSettings.h>

Expected Behaviour The build to run smooth again.

Steps to Reproduce It happens on two different build servers independent of a branch to build.

Thanks so much for any idea what this could cause it all of a sudden.

Issue Analytics

  • State:open
  • Created 2 years ago
  • Comments:18

github_iconTop GitHub Comments

Kweizacommented, Jan 4, 2022

I solved this problem.

try install ‘react-native-fbsdk’

yarn add react-native-fbsdk

And if you see an error message “The SDK version in the ad request is no longer supported for new apps. Please upgrade to the latest version of the SDK”, edit sdk version in react-native-fbads/android/app/build.gradle

I made a PR for this. you can see at sdk version error fixed

taschikcommented, Nov 25, 2021

I am reopening this since the issue resurfaces when upgrading to Facebook iOS SDK v12. My current environment is:

    OS: macOS 12.0.1
    CPU: (12) x64 Intel(R) Core(TM) i9-8950HK CPU @ 2.90GHz
    Memory: 25.21 MB / 32.00 GB
    Shell: 5.8 - /bin/zsh
    Node: 14.17.5 - ~/.nvm/versions/node/v14.17.5/bin/node
    Yarn: 1.22.17 - ~/.nvm/versions/node/v14.17.5/bin/yarn
    npm: 8.1.0 - ~/.nvm/versions/node/v14.17.5/bin/npm
    Watchman: 2021.06.07.00 - /usr/local/bin/watchman
    CocoaPods: 1.11.2 - /usr/local/bin/pod
    iOS SDK:
      Platforms: DriverKit 21.0.1, iOS 15.0, macOS 12.0, tvOS 15.0, watchOS 8.0
    Android SDK:
      API Levels: 23, 26, 27, 28, 29
      Build Tools: 23.0.1, 25.0.0, 26.0.3, 27.0.3, 28.0.1, 28.0.2, 28.0.3
      Android NDK: Not Found
    Android Studio: 3.6 AI-192.7142.36.36.6308749
    Xcode: 13.1/13A1030d - /usr/bin/xcodebuild
    Java: 1.8.0_221 - /usr/bin/javac
    @react-native-community/cli: Not Found
    react: 17.0.2 => 17.0.2
    react-native: 0.66.3 => 0.66.3
    react-native-macos: Not Found
    *react-native*: Not Found

My Podfile contains the following line:

  # Facebook
  pod 'FBSDKCoreKit', '~> 12.1'

Anyone that got v12 to work with react-native-fbads?

Read more comments on GitHub >

github_iconTop Results From Across the Web

FBSDKCoreKit/FBSDKCoreKit.h not found error - Stack Overflow
1.Make sure that the Facebook SDK frameworks are installed in ~/Documents/FacebookSDK. 2)Make sure that FBSDK[Core, Login, Share]Kit ...
Read more >
'FBSDKCoreKit/FBSDKCoreKit.h' file not found - Unity Forum
I'm building in unity on windows, then transferring the build to a mac to build to iPhone. It was all working fine until...
Read more >
[Solved]-'FBSDKCoreKit/FBSDKSettings.h' file not found
Coding example for the question 'FBSDKCoreKit/FBSDKSettings.h' file not found. ... error and tried every solution I found in their corresponding github repo ...
Read more >
Changelog - GitHub
[2022-10-24]( ... Rule match for fb_content - Fixed: 'FBSDKCoreKitImport.h' file not found.
Read more >
Facebook SDK for iOS - Meta for Developers
Integrate your iOS app with Facebook to build engaging social apps by using the Facebook SDK for iOS.
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found