Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Error when adding new product

See original GitHub issue

Hi, I seem to have encountered a few issues, namely when I add a new product I get this error: image

Here’s my schema, I’ve tried it with even just a few fields, I still get the same error when adding the product (even though the product gets added successfully…)

export const DBproductSchema = buildSchema<DBProduct>({
    name: "Product",
    properties: {
        imageUrl: imageUrlDisplay,

        name: {
            title: "Name",
            validation: { required: true },
            dataType: "string"

            title: "Searchable name",
            validation: {required: true},
            dataType: "string"

            title: "Typical shelf life",
            validation: { required: true },
            dataType: "string"

        typicallyStoredIn: {
            title: "Typically stored in",
            validation: { required: true },
            dataType: "string",

            config: {
                enumValues: {
                    "Šaldytuve": "Šaldytuve",
                    "Šaldiklyje": "Šaldiklyje",
                    "Lentynoje": "Lentynoje",
                    "Rūsyje": "Rūsyje"

            title: "Drinkable",
            validation: {required: false},
            dataType: "boolean"
            title: "Weighable",
            validation: {required: false},
            dataType: "boolean"
            title: "Countable",
            validation: {required: false},
            dataType: "boolean"
            title: "Can't expire",
            validation: {required: false},
            dataType: "boolean"

        category: {
            title: "Category",
            validation: { required: true },
            dataType: "string",
                enumValues: {
                    "-": "-",
                    "Pieno produktai": "Pieno produktai",
                    "Vaisiai": "Vaisiai",
                    "Daržovės": "Daržovės",
                    "Prieskoniai": "Prieskoniai",

What am i doing wrong?

Issue Analytics

  • State:closed
  • Created a year ago
  • Comments:6 (3 by maintainers)

github_iconTop GitHub Comments

Adkaroscommented, Jun 1, 2022

I’m able to reproduce the same exact issue, using react 18.1.0.

Seems to happen with the demo code included in quickstart

fgatti675commented, Jun 2, 2022

Hi guys, we will be working on making FireCMS 1.0 compatible with React 18. In the meantime, I could make it work reverting to previous dependencies:


  "name": "my-cms",
  "version": "0.1.0",
  "private": true,
  "dependencies": {
    "@camberi/firecms": "^1.0.0",
    "@emotion/react": "^11.7.1",
    "@emotion/styled": "^11.6.0",
    "@mui/icons-material": "^5",
    "@mui/lab": "^5.0.0-alpha.68",
    "@mui/material": "^5",
    "@mui/styles": "^5",
    "@types/jest": "^27.0.1",
    "@types/node": "^16.7.13",
    "@types/react": "^17.0.20",
    "@types/react-dom": "^17.0.9",
    "firebase": "^9",
    "react": "^17.0.2",
    "react-dom": "^17.0.2",
    "react-router": "^6",
    "react-router-dom": "^6",
    "react-scripts": "5.0.0",
    "typescript": "^4.4.2",
    "web-vitals": "^2.1.0"
  "scripts": {
    "start": "react-scripts start",
    "build": "react-scripts build",
    "test": "react-scripts test",
    "eject": "react-scripts eject"
  "eslintConfig": {
    "extends": [
  "browserslist": {
    "production": [
      "not dead",
      "not op_mini all"
    "development": [
      "last 1 chrome version",
      "last 1 firefox version",
      "last 1 safari version"

and index.tsx:

import React from 'react';
import ReactDOM from "react-dom";

import './index.css';
import App from './App';
import reportWebVitals from './reportWebVitals';


// If you want to start measuring performance in your app, pass a function
// to log results (for example: reportWebVitals(console.log))
// or send to an analytics endpoint. Learn more:
Read more comments on GitHub >

github_iconTop Results From Across the Web

Server Error-Error Message When Adding New Products
I am trying to add new products to my store because I am a few days away from my launch. Everything was going...
Read more >
Error That makes No sense when Adding a new product
I am adding them straight on the amazon seller site and not using the upload file because its only one item.
Read more >
Issues Adding Product – Critical Error
I have installed woocommerce and when I try to add a product I get this message: There has been a critical error on...
Read more >
Error when adding new product. please help!
I have installed the latest version and everything seemed fine, but when trying to add a new Product... this is what I get....
Read more >
Error When Adding New Product - Microsoft Dynamics CRM ...
Error When Adding New Product ... I am thinking , business rule to automatically set the Default Unit and Unit Group on the...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found