Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Getting webpack error when running 'gatsby develop'

See original GitHub issue

Detailed description

I followed the getting started guide here

But when I tried to run gatsby run dev, I get the error as shown in the screenshot.


Note: This issue only appears on Windows and Ubuntu. The funny thing is that it works fione on Mac.

Any help would be much appreciated. Thanks


Issue Analytics

  • State:closed
  • Created 3 years ago
  • Comments:7 (3 by maintainers)

github_iconTop GitHub Comments

se4m0recommented, Aug 31, 2020

I do see the error on my Mac. Deleting lines 135 and 254 in /pages/components/markdown.mdx resolves the error. It appears that, outside of code blocks, text with angle brackets inlined and html comments (<!-- -->) are not valid.

Changing the package manager from npm to yarn fixed it. The errors in markdown.mdx disappeared too.

vpiconecommented, Oct 6, 2020

Closing as this is an upstream issue.

Read more comments on GitHub >

github_iconTop Results From Across the Web

Webpack error #98123 when running "gatsby develop" #17557
This error was introduced by updating an ESLint plugin, which is not related to Gatsby at all. My workaround is to delete yarn.lock...
Read more >
ERROR #98123 WEBPACK Generating development ...
I installed a new Gatsby site, no plugins, and when making simple HTML changes, then previewing the DEVELOP site and refreshing, every time...
Read more >
Adding a Custom webpack Config - Gatsby
Before creating custom webpack configuration, check to see if there's a Gatsby plugin already built that handles your use case in the plugins...
Read more >
Gatsby Changelog | 5.3.0
Show original stack trace from workers. You might have run into an error like this while using Gatsby: ERROR #85928 An error occurred...
Read more >
Gatsby Develop ERROR #98123 WEBPACK, Generating SSR ...
Hi, I'm new to using gatsby and am attempting to follow the tutorial on I have been su... Tagged with gatsby, webpack, ......
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found