Stuck on an issue?

Lightrun Answers was designed to reduce the constant googling that comes with debugging 3rd party libraries. It collects links to all the places you might be looking at while hunting down a tough bug.

And, if you’re still stuck at the end, we’re happy to hop on a call to see how we can help out.

Unable to or cc.query

See original GitHub issue

Hello! I’ve been trying to do and cc.query using cartoframes. When I try and run it I get this error message:

<ipython-input-54-d98adbbbcfad> in <module>()
----> 1 assigned ='us_counties_assigned')
      2 unassigned ='us_counties_unassigned')

/Users/mspichiger/venv/lib/python2.7/site-packages/cartoframes/context.pyc in read(self, table_name, limit, index, decode_geom, shared_user)
    192                 raise ValueError("`limit` parameter must an integer >= 0")
--> 194         return self.query(query, decode_geom=decode_geom)
    196     def write(self, df, table_name, temp_dir=CACHE_DIR, overwrite=False,

/Users/mspichiger/venv/lib/python2.7/site-packages/cartoframes/context.pyc in query(self, query, table_name, decode_geom)
    728                 query,
    729                 skipfields='the_geom_webmercator',
--> 730                 **DEFAULT_SQL_ARGS)
    731             if 'error' in select_res:
    732                 raise CartoException(str(select_res['error']))

/Users/mspichiger/venv/lib/python2.7/site-packages/carto/sql.pyc in send(self, sql, parse_json, do_post, format, **request_args)
     84             return self.auth_client.get_response_data(resp, parse_json)
     85         except Exception as e:
---> 86             raise CartoException(e)

CartoException: Unterminated string starting at: line 1 column 1349219 (char 1349218)

The confusing part is that every time I run the command I get a new column value. In the example I gave the number is 1349219, but I also get 2981871 (char 2981870), 1266002 (char 1266001), and many more seemingly random columns. The dataset I’m trying to read is about 6.6 MB and has 18 columns. I’ve included the table here:

Let me know if there’s anything I can do to help.

Issue Analytics

  • State:closed
  • Created 5 years ago
  • Comments:23 (8 by maintainers)

github_iconTop GitHub Comments

andy-eschcommented, Aug 24, 2018
MichaelSpichigercommented, Aug 16, 2018

Hello, my user is mspichigercarto, the table target_1 is failing and it’s not even that large. It’s 15 rows by 12 columns. I also notice that other tables that are larger work fine and SOMETIMES reseting the index and dropping the cartodb_id works. It’s not consistent though.

Hope this helps

Read more comments on GitHub >

github_iconTop Results From Across the Web

ERROR Failed to query stereo recording #4351
Hello. My test run stopped prematurely right after this log message: [4861:0521/] Failed to query ...
Read more >
Outlook.MailItem - Unable to get To, CC & BCC from Outlook
I tried using To/CC/BCC without saving the mailItem but iterating from Recipients Object.But got the result like an ldap query.../O=SOMEVALUE/OU ...
Read more >
I am trying to cc logged in user in email script,but it is not working
I have tried below script but not able to cc the logged in user, it is not working in email scripts but in...
Read more >
Not letting me cc another user - HubSpot Community
I would like to cc another user and my super admin and I are working together to fix the problem. We have gone...
Read more >
Email CC Recipients - Support - Mautic Community Forums
Any ideas to fix this issue? This is because Mautic sends the email as a copy but does not show the people who...
Read more >

github_iconTop Related Medium Post

No results found

github_iconTop Related StackOverflow Question

No results found

github_iconTroubleshoot Live Code

Lightrun enables developers to add logs, metrics and snapshots to live code - no restarts or redeploys required.
Start Free

github_iconTop Related Reddit Thread

No results found

github_iconTop Related Hackernoon Post

No results found

github_iconTop Related Tweet

No results found

github_iconTop Related Post

No results found

github_iconTop Related Hashnode Post

No results found